summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-26 11:21:07 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-02-08 14:50:02 +0200
commit7a46581d174d586a01e661b0179c273c97da991e (patch)
treec6bc96b643a64691c8c5debb71ff8cef96c3e1a3
parentgames-strategy/freeorion: enable py3.11 (diff)
downloadgentoo-7a46581d174d586a01e661b0179c273c97da991e.tar.gz
gentoo-7a46581d174d586a01e661b0179c273c97da991e.tar.bz2
gentoo-7a46581d174d586a01e661b0179c273c97da991e.zip
media-fonts/source-serif: add 4.005
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/29277 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--media-fonts/source-serif/Manifest1
-rw-r--r--media-fonts/source-serif/source-serif-4.005.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-fonts/source-serif/Manifest b/media-fonts/source-serif/Manifest
index 494b051bf018..0cc7fe50f9e9 100644
--- a/media-fonts/source-serif/Manifest
+++ b/media-fonts/source-serif/Manifest
@@ -1 +1,2 @@
DIST source-serif-4.004.tar.gz 40747188 BLAKE2B 9c91fbb5d9b29c28e1e64f36e410afce8ae6f0e6d030a6ee4e6069a20d270bf7852967641eb54b33bfe9a23eae024448f6c22de25d766a9f8a830cce04d29db1 SHA512 fff923121f1d536886468fd4887e036d9d85603e57c4ecabe64f73af4506b15265481ca69cbe7d83751f93ff72f7f9dce3aae56dacdd2c4da1bc1e7285f76d6b
+DIST source-serif-4.005.tar.gz 41743303 BLAKE2B 7dec81fd559a0bf620b2351dc26f2a481825a77148019797b5726699cc3e5977194278e8ef5cc6acd2dea8e30f8b19afa12dd301abbbf75bb192a9e7bfbde51d SHA512 c2dc7c036d02946a9585a9d9b1ef4fe458f77586d83d0e4c3084d62394f02103821273911c22be8a8fe28e116f4baca621026cac9054927243574264cad9ee52
diff --git a/media-fonts/source-serif/source-serif-4.005.ebuild b/media-fonts/source-serif/source-serif-4.005.ebuild
new file mode 100644
index 000000000000..596bb8c2182a
--- /dev/null
+++ b/media-fonts/source-serif/source-serif-4.005.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJORV="${PV%%.*}"
+FONT_PN=${PN}-${MAJORV}
+
+inherit font optfeature
+
+DESCRIPTION="Serif font family for user interface environments"
+HOMEPAGE="https://adobe-fonts.github.io/source-serif/"
+SRC_URI="https://github.com/adobe-fonts/source-serif/archive/${PV}R.tar.gz -> source-serif-${PV}.tar.gz"
+S="${WORKDIR}/${P}R"
+
+LICENSE="OFL-1.1"
+SLOT="${MAJORV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RESTRICT="binchecks strip"
+
+RDEPEND="media-libs/fontconfig"
+
+FONT_CONF=( "${FILESDIR}"/63-${FONT_PN}.conf )
+FONT_SUFFIX="otf"
+
+src_prepare() {
+ default
+ mv OTF/*.otf . || die
+}
+
+pkg_postinst() {
+ optfeature_header "Other variants of this font are:"
+ optfeature "the monospace variant" media-fonts/source-code-pro
+ optfeature "Chinese, Japanese and Korean support" media-fonts/source-han-sans
+ optfeature "the sans-serif variant" media-fonts/source-sans
+}