summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-11 06:53:23 +0100
committerSam James <sam@gentoo.org>2022-06-11 06:53:23 +0100
commit7e27203cbdad242722e9bf58362068246a091fab (patch)
tree343bd51ecad59ba693a7e91f817d6d8ef0cb02fd
parentsys-apps/dchroot: drop Werror (diff)
downloadgentoo-7e27203c.tar.gz
gentoo-7e27203c.tar.bz2
gentoo-7e27203c.zip
sys-kernel/kpatch: drop Werror
Closes: https://bugs.gentoo.org/776925 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-kernel/kpatch/files/kpatch-0.9.4-no-werror.patch12
-rw-r--r--sys-kernel/kpatch/kpatch-0.9.4.ebuild4
2 files changed, 16 insertions, 0 deletions
diff --git a/sys-kernel/kpatch/files/kpatch-0.9.4-no-werror.patch b/sys-kernel/kpatch/files/kpatch-0.9.4-no-werror.patch
new file mode 100644
index 000000000000..0667fdd91ca1
--- /dev/null
+++ b/sys-kernel/kpatch/files/kpatch-0.9.4-no-werror.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/776925
+--- a/kpatch-build/Makefile
++++ b/kpatch-build/Makefile
+@@ -1,7 +1,7 @@
+ include ../Makefile.inc
+
+ CFLAGS += -MMD -MP -I../kmod/patch -Iinsn -Wall -Wsign-compare \
+- -Wconversion -Wno-sign-conversion -g -Werror
++ -Wconversion -Wno-sign-conversion -g
+ LDLIBS = -lelf
+
+ TARGETS = create-diff-object create-klp-module create-kpatch-module
diff --git a/sys-kernel/kpatch/kpatch-0.9.4.ebuild b/sys-kernel/kpatch/kpatch-0.9.4.ebuild
index 5cdcff76d491..e30e6e2e09cf 100644
--- a/sys-kernel/kpatch/kpatch-0.9.4.ebuild
+++ b/sys-kernel/kpatch/kpatch-0.9.4.ebuild
@@ -34,6 +34,10 @@ DEPEND="
test? ( dev-util/shellcheck-bin )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.4-no-werror.patch
+)
+
pkg_setup() {
if use kmod; then
if kernel_is gt 3 9 0; then