summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-04-08 21:25:21 +0100
committerMarek Szuba <marecki@gentoo.org>2023-04-08 21:56:25 +0100
commit8086b07eec8f590e6e00afa07f447d2f206c070c (patch)
tree391eaee3557bf48f57ef65ff83bea9f1e21fee56
parentdev-libs/libvterm: add 0.3.1 (diff)
downloadgentoo-8086b07eec8f590e6e00afa07f447d2f206c070c.tar.gz
gentoo-8086b07eec8f590e6e00afa07f447d2f206c070c.tar.bz2
gentoo-8086b07eec8f590e6e00afa07f447d2f206c070c.zip
app-vim/vim-flake8: add 1.7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-vim/vim-flake8/Manifest1
-rw-r--r--app-vim/vim-flake8/vim-flake8-1.7.ebuild16
2 files changed, 17 insertions, 0 deletions
diff --git a/app-vim/vim-flake8/Manifest b/app-vim/vim-flake8/Manifest
index d44e59d86df7..cb759c7adb26 100644
--- a/app-vim/vim-flake8/Manifest
+++ b/app-vim/vim-flake8/Manifest
@@ -1 +1,2 @@
DIST vim-flake8-1.6.tar.gz 5345 BLAKE2B dd726798a49231841f9fcb915999cf965a42b8b5f593a66f97268bc6d7993584d5f9ed0cfc50508bc57d60c5dcd19c8476e86ae26fb8be9c1dcf7007db2d0323 SHA512 a4208478f9754ef2d188a51e3262c449ef16b48fc0208425795d71c304118c129ae20a723fff96863291bae66237f1479a591cc23e5ec90222e0614d2dcccce9
+DIST vim-flake8-1.7.tar.gz 6080 BLAKE2B bf78e2c4e9976fc148cf18fc5ec58c2807a9c82a6893160ca4a107664d438fc955c2eac3e41373529cc1dc5295acab06c7c9007c1ad72095548362e903d7d31a SHA512 c29cfc00e4fd94128be02e003116647819cd3b39916527b70a7684c19ef4184bce1c1556051fc269bde4696a98b752fb7b4e081c2aac46cdcdfdf35735ec76b0
diff --git a/app-vim/vim-flake8/vim-flake8-1.7.ebuild b/app-vim/vim-flake8/vim-flake8-1.7.ebuild
new file mode 100644
index 000000000000..b8772d16ea7d
--- /dev/null
+++ b/app-vim/vim-flake8/vim-flake8-1.7.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: runs the currently open file through flake8"
+HOMEPAGE="https://github.com/nvie/vim-flake8"
+SRC_URI="https://github.com/nvie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/flake8"