summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Glorg <eugene@railglorg.net>2022-02-23 21:41:55 +0200
committerSam James <sam@gentoo.org>2022-02-26 02:36:27 +0000
commit80d5d4f48c0f6a6810a6e823e54aa0ec2c62cca1 (patch)
treeba85ffb57e8c15be27b7573727f35c68aa10b75f
parentgui-libs/wlroots: sync live ebuild (diff)
downloadgentoo-80d5d4f48c0f6a6810a6e823e54aa0ec2c62cca1.tar.gz
gentoo-80d5d4f48c0f6a6810a6e823e54aa0ec2c62cca1.tar.bz2
gentoo-80d5d4f48c0f6a6810a6e823e54aa0ec2c62cca1.zip
net-misc/balance: add net_bind_service capability
This changes binary capabilities and allows binding to privileged ports for non-root Signed-off-by: Eugene Glorg <glorg@railglorg.net> Closes: https://github.com/gentoo/gentoo/pull/24325 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/balance/balance-3.57-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/balance/balance-3.57-r1.ebuild b/net-misc/balance/balance-3.57-r1.ebuild
new file mode 100644
index 000000000000..b988c64b8a44
--- /dev/null
+++ b/net-misc/balance/balance-3.57-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps toolchain-funcs
+
+DESCRIPTION="TCP Load Balancing Port Forwarder"
+HOMEPAGE="http://www.inlab.de/balance.html"
+SRC_URI="http://www.inlab.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+FILECAPS=(
+ 'CAP_NET_BIND_SERVICE' '/usr/sbin/balance'
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ #autocreated on program start, if missing
+ rm -rv "${ED}/var/run" || die
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ elog "To run as non-root, be sure to have rendezvous directory created"
+ elog "with either 'mkdir -m 01777 /var/run/balance' or using tmpfiles."
+}