summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/balance/balance-3.57-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/balance/balance-3.57-r1.ebuild b/net-misc/balance/balance-3.57-r1.ebuild
new file mode 100644
index 000000000000..b988c64b8a44
--- /dev/null
+++ b/net-misc/balance/balance-3.57-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps toolchain-funcs
+
+DESCRIPTION="TCP Load Balancing Port Forwarder"
+HOMEPAGE="http://www.inlab.de/balance.html"
+SRC_URI="http://www.inlab.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+FILECAPS=(
+ 'CAP_NET_BIND_SERVICE' '/usr/sbin/balance'
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ #autocreated on program start, if missing
+ rm -rv "${ED}/var/run" || die
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ elog "To run as non-root, be sure to have rendezvous directory created"
+ elog "with either 'mkdir -m 01777 /var/run/balance' or using tmpfiles."
+}