summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-30 06:50:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-30 07:02:35 +0200
commit8162c78166aaad5a35cafe084e52e3d36a5a7ee2 (patch)
tree60a25a10299e501894e689b5d3f894a894b2e897
parentdev-python/Faker: Bump to 25.0.0 (diff)
downloadgentoo-8162c78166aaad5a35cafe084e52e3d36a5a7ee2.tar.gz
gentoo-8162c78166aaad5a35cafe084e52e3d36a5a7ee2.tar.bz2
gentoo-8162c78166aaad5a35cafe084e52e3d36a5a7ee2.zip
dev-python/filelock: Bump to 3.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.14.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 82d779b519a7..58d1c85d1f67 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1 +1,2 @@
DIST filelock-3.13.4.tar.gz 15093 BLAKE2B 1ee07531e4743ad61e9fc2ef85d79e1402be75efb31a6661e1f912a3ae44d19e5578e6e78980228645157ab254f56070ee85b2cdcd2e9d507947c778284159d4 SHA512 072d78bfb3b3831847103b3e7d54e97e9486cbe1ba146d9632edb510abe2d56f3f06bce6b79a2e6cb830ba51e47bbfe32b8f18abb08bd33480ecf78ee0da161b
+DIST filelock-3.14.0.tar.gz 15401 BLAKE2B afa95a941189cd73767684016502fba6972541a8a0f16bed0a4acc6452700224d511a17e6882b1c680fa6b20621b617704a7e9d3aff8ae883ede56f40acb5de3 SHA512 51eda6394fcac86a12887fe1974022b9da921fb96a61887f7a91c5b15f083a4c9186600ec61b4e93b91b8c4799c50ca4b6c418416c6bf2b422ea3b41715258e4
diff --git a/dev-python/filelock/filelock-3.14.0.ebuild b/dev-python/filelock/filelock-3.14.0.ebuild
new file mode 100644
index 000000000000..48908464f081
--- /dev/null
+++ b/dev-python/filelock/filelock-3.14.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/filelock/
+ https://pypi.org/project/filelock/
+"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest