summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-27 08:08:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-27 09:00:18 +0200
commit81873ee6a8ef2447546116609fd8825b0bc167ff (patch)
tree61e53860d596e51b2aa9b222e2d4ac32d6cd278c
parentdev-python/pytest-mock: Bump to 3.3.1 (diff)
downloadgentoo-81873ee6.tar.gz
gentoo-81873ee6.tar.bz2
gentoo-81873ee6.zip
dev-python/botocore: Bump to 1.17.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.17.49.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 3f816d060ce3..339014c30e59 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.17.23.tar.gz 6564852 BLAKE2B cc1da91f4a45964fe684b015de9db253059241f654dac93901cde5dc24f3ab3595ecd201be91bed36236bb885c7ec7aed998025f6c0ea8b050c13d17a6431238 SHA512 93af672e8d110ab4989e9abc20b3bbb1a6c9050c379bb1db8542e9027e6a4ee82083645c59211204d7110e112d393f80f87d15b77337a4d73358f43d39f6e52f
DIST botocore-1.17.31.tar.gz 6665851 BLAKE2B dbc89d1216f9fda89c6185baccfdf2878c265d8761e4ad1349a45d334f9a4d5b79ad1ce06a19a7a706b75be1a6d7f2a7bf5bc33d8ffbe7ad8a016472edf0432f SHA512 ab1921fae887846d1c224d624e8d5dd888ab9c0c90a415ac97e5ad2f7563131b199e8870553e7f3dd6f5ff4c7901aa04bfa99160aca4e9da8ef3096cfd922ec9
DIST botocore-1.17.46.tar.gz 6738493 BLAKE2B 2e5ee1241af91c19cef0ac575c5ad68d46277e8b2f0f1f719428f7b4026303a47e48b8a8240c1121cfe35c6310be5fde3f0cfa2aa3f3321249811eb510b47f94 SHA512 a11de252454477d478f2b5d0b5978b24961baa3942936ef5990c421709d0b8081e8dbf020b76cce5c3c43d3fe0467cedf5441918767163712e0ad178c9cba80d
+DIST botocore-1.17.49.tar.gz 6765351 BLAKE2B c5c40c37d1f1f0f1d7e059a1b88025039be6021723d244725de28d453789a51b19c4feed35d7c862a8238e5d2b4d77fb83f0b0052ce7a7b31c26e024b7be4321 SHA512 912a25c98fa08a89aa8511f00a83712525eaa11a1c8137da3e569a993c54d2c2a3c9566ff88f91cede34dc1d1b155f21ac037f2396b3b3339ddc2c2be7c400d1
diff --git a/dev-python/botocore/botocore-1.17.49.ebuild b/dev-python/botocore/botocore-1.17.49.ebuild
new file mode 100644
index 000000000000..8737f742498b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.17.49.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.16.7-unlock-deps.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # py3.9
+ find -name '*.py' -exec \
+ sed -i -e 's:cElementTree:ElementTree:' {} + || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}