summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-28 00:42:54 -0400
committerSam James <sam@gentoo.org>2024-04-28 07:54:25 +0100
commit84e655a1f462a58154b701b9b8077ebf3071e82f (patch)
treec3e07880f62dc020404b1a8c8df1d26188767b23
parentdev-perl/Archive-Tar-Wrapper: add 0.390.0 (diff)
downloadgentoo-84e655a1f462a58154b701b9b8077ebf3071e82f.tar.gz
gentoo-84e655a1f462a58154b701b9b8077ebf3071e82f.tar.bz2
gentoo-84e655a1f462a58154b701b9b8077ebf3071e82f.zip
sys-fs/squashfs-tools-ng: run elibtoolize in non-live ebuild
When building live, we always run eautoreconf. However, even in release mode we should still run elibtoolize to get important fixes -- such as the ones that pass through LTO sanity flags to the link phase. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild9
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild9
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild7
3 files changed, 20 insertions, 5 deletions
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild
index dc4fd0581812..a4168be5e3b8 100644
--- a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,6 +9,7 @@ if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
+ inherit libtool
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi
@@ -30,7 +31,11 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
- [[ ${PV} == "9999" ]] && eautoreconf
+ if [[ ${PV} = "9999" ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_configure() {
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild
index c143cfb54ab2..f936c78e267e 100644
--- a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild
@@ -9,7 +9,8 @@ if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ inherit libtool
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi
@@ -30,7 +31,11 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
- [[ ${PV} == "9999" ]] && eautoreconf
+ if [[ ${PV} = "9999" ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_configure() {
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
index 161eca8ce48e..f936c78e267e 100644
--- a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
@@ -9,6 +9,7 @@ if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
+ inherit libtool
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi
@@ -30,7 +31,11 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
- [[ ${PV} == "9999" ]] && eautoreconf
+ if [[ ${PV} = "9999" ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_configure() {