summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:45:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:28 +0200
commit8509001fc44510651ef7919cf88c74fc23a0e98f (patch)
treea346b6eec14840987aecb3bd72b4d1d6eaf6f49f
parentdev-ros/rosnode: Initial import. Ebuild by me. (diff)
downloadgentoo-8509001fc44510651ef7919cf88c74fc23a0e98f.tar.gz
gentoo-8509001fc44510651ef7919cf88c74fc23a0e98f.tar.bz2
gentoo-8509001fc44510651ef7919cf88c74fc23a0e98f.zip
dev-ros/rosservice: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/rosservice/Manifest1
-rw-r--r--dev-ros/rosservice/metadata.xml5
-rw-r--r--dev-ros/rosservice/rosservice-1.11.14.ebuild25
-rw-r--r--dev-ros/rosservice/rosservice-9999.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/rosservice/Manifest b/dev-ros/rosservice/Manifest
new file mode 100644
index 000000000000..84bda7639707
--- /dev/null
+++ b/dev-ros/rosservice/Manifest
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/rosservice/metadata.xml b/dev-ros/rosservice/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosservice/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosservice/rosservice-1.11.14.ebuild b/dev-ros/rosservice/rosservice-1.11.14.ebuild
new file mode 100644
index 000000000000..05fb1e6f2599
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.11.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosservice/rosservice-9999.ebuild b/dev-ros/rosservice/rosservice-9999.ebuild
new file mode 100644
index 000000000000..05fb1e6f2599
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"