summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-07-27 08:12:13 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-07-27 08:16:00 -0700
commit855758894ff8827c6b8d5e3f9465d1a01138d0a2 (patch)
tree1bec5efcf24f6e73880aa6d2c1495375a23b0f22
parentAdded media-plugins/kodi-imagedecoder-heif kodi binary plugin Add support for... (diff)
downloadgentoo-855758894ff8827c6b8d5e3f9465d1a01138d0a2.tar.gz
gentoo-855758894ff8827c6b8d5e3f9465d1a01138d0a2.tar.bz2
gentoo-855758894ff8827c6b8d5e3f9465d1a01138d0a2.zip
dev-python/tubes: Revision bump, remove unnecessary dep
setup.py was still listing characteristic as a dep but was not needed. Closes: https://bugs.gentoo.org/733936 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
-rw-r--r--dev-python/tubes/files/remove-unnecessary-dep.patch24
-rw-r--r--dev-python/tubes/metadata.xml17
-rw-r--r--dev-python/tubes/tubes-0.2.0-r1.ebuild (renamed from dev-python/tubes/tubes-0.2.0.ebuild)10
3 files changed, 33 insertions, 18 deletions
diff --git a/dev-python/tubes/files/remove-unnecessary-dep.patch b/dev-python/tubes/files/remove-unnecessary-dep.patch
new file mode 100644
index 000000000000..678f3c27abd8
--- /dev/null
+++ b/dev-python/tubes/files/remove-unnecessary-dep.patch
@@ -0,0 +1,24 @@
+From 2c05dd8f27c97ebbfea18706ff54d2406448b09a Mon Sep 17 00:00:00 2001
+From: Glyph <glyph@twistedmatrix.com>
+Date: Tue, 3 Mar 2020 01:24:13 -0800
+Subject: [PATCH] remove unnecessary dependency
+
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index c647927..e9e3134 100644
+--- a/setup.py
++++ b/setup.py
+@@ -16,7 +16,6 @@ setup(
+ packages=find_packages(exclude=[]),
+ package_dir={'tubes': 'tubes'},
+ install_requires=[
+- "characteristic",
+ "six",
+ "Twisted",
+ ],
+--
+libgit2 1.0.1
+
diff --git a/dev-python/tubes/metadata.xml b/dev-python/tubes/metadata.xml
index 77d7b556b447..a67569e9a9d4 100644
--- a/dev-python/tubes/metadata.xml
+++ b/dev-python/tubes/metadata.xml
@@ -7,17 +7,14 @@
</maintainer>
<upstream>
<maintainer>
- <email>bolson@bolson.org</email>
- <name>Brian Olson</name>
+ <email>glyph@twistedmatrix.com</email>
+ <name>glyph</name>
</maintainer>
- <remote-id type="pypi">cbor</remote-id>
- <remote-id type="bitbucket">bodhisnarkva/cbor</remote-id>
+ <remote-id type="pypi">Tubes</remote-id>
+ <remote-id type="github">twisted/tubes</remote-id>
</upstream>
- <longdescription>This library provides encoding and decoding for the
-Concise Binary Object Representation (CBOR) (RFC 7049) serialization format.
-It is implemented in pure python with an optional C backend and is compatible
-with versions 2.7 through to 3.8. On cPython>=3.3 cbor2 can use a built in C
-module for performance similar to how pickle wraps the _pickle C module in the
-Python Standard Library.
+ <longdescription>Presently based primarily on Twisted, its core data
+ structures are fairly framework-agnostic and could be repurposed to work
+ with any event-driven container.
</longdescription>
</pkgmetadata>
diff --git a/dev-python/tubes/tubes-0.2.0.ebuild b/dev-python/tubes/tubes-0.2.0-r1.ebuild
index 6e7b2f17ad58..e9e16492a5cb 100644
--- a/dev-python/tubes/tubes-0.2.0.ebuild
+++ b/dev-python/tubes/tubes-0.2.0-r1.ebuild
@@ -11,9 +11,6 @@ DESCRIPTION="Flow control and backpressure for event-driven applications"
HOMEPAGE="https://github.com/twisted/tubes https://pypi.org/project/Tubes/"
SRC_URI="https://github.com/twisted/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 "
@@ -22,12 +19,9 @@ DEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/twisted[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
RDEPEND="${DEPEND}"
+PATCHES=( "$FILESDIR/remove-unnecessary-dep.patch")
+
distutils_enable_tests pytest