summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-01 06:20:38 +0000
committerSam James <sam@gentoo.org>2021-01-01 22:21:53 +0000
commit85d706b3d2841c4bc90293f8e527ab087c4832ce (patch)
treeb38e3963091d315cb849b17de07d4190c3748fd7
parentnet-irc/inspircd: Update HOMEPAGE (diff)
downloadgentoo-85d706b3.tar.gz
gentoo-85d706b3.tar.bz2
gentoo-85d706b3.zip
media-libs/bcg729: don't use -Werror
Closes: https://bugs.gentoo.org/751301 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/bcg729/bcg729-1.0.4-r1.ebuild7
-rw-r--r--media-libs/bcg729/bcg729-1.1.1.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/media-libs/bcg729/bcg729-1.0.4-r1.ebuild b/media-libs/bcg729/bcg729-1.0.4-r1.ebuild
index ce3201c782e7..04926f70bcfb 100644
--- a/media-libs/bcg729/bcg729-1.0.4-r1.ebuild
+++ b/media-libs/bcg729/bcg729-1.0.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,11 @@ RDEPEND="
S=${WORKDIR}/${P/_/-}
DOCS=( AUTHORS NEWS README.md )
+src_prepare() {
+ sed -i -e '/-Werror/d' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
src_configure() {
mycmakeargs=(
-DENABLE_STATIC=$(usex static-libs)
diff --git a/media-libs/bcg729/bcg729-1.1.1.ebuild b/media-libs/bcg729/bcg729-1.1.1.ebuild
index e724197e7cff..3a492a09a321 100644
--- a/media-libs/bcg729/bcg729-1.1.1.ebuild
+++ b/media-libs/bcg729/bcg729-1.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,6 +17,11 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ppc64 ~x86"
RDEPEND="!media-plugins/mediastreamer-bcg729"
+src_prepare() {
+ sed -i -e 's/-Werror //' CMakeLists.txt || die
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_STATIC=no