summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-25 09:55:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-25 10:18:39 +0200
commit861aa80d44de86bb31c01be8fc96a399ec446c9a (patch)
treee41e7d259b60eb526419e4c5f7c62c569bf8560d
parentdev-python/imageio: Bump to 2.18.0 (diff)
downloadgentoo-861aa80d44de86bb31c01be8fc96a399ec446c9a.tar.gz
gentoo-861aa80d44de86bb31c01be8fc96a399ec446c9a.tar.bz2
gentoo-861aa80d44de86bb31c01be8fc96a399ec446c9a.zip
dev-python/fuse-python: Bump to 1.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fuse-python/Manifest1
-rw-r--r--dev-python/fuse-python/fuse-python-1.0.5.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/fuse-python/Manifest b/dev-python/fuse-python/Manifest
index baec9fb9407a..d3574c776669 100644
--- a/dev-python/fuse-python/Manifest
+++ b/dev-python/fuse-python/Manifest
@@ -1 +1,2 @@
DIST python-fuse-1.0.4.tar.gz 46571 BLAKE2B b839043343e5abda2725545c696afd4da847e33a77647d910bc7ea71d17480536770d99899ae8f949734304ea6b4b591934f34476ea84aad1adbe39ee5897fa7 SHA512 48fffc02aa7125df03cf2a5819449a5e10a772ecc737bc8a19199beca6a2f8181b98c91cf05fedd06fc258d846c8d67d073dc1e8620c336a3ae09320688dc389
+DIST python-fuse-1.0.5.tar.gz 46592 BLAKE2B 9d33cf508a57b1a08f6c257ecee89386826f5f6c9be223f33c36789930baccaacab112305e264aa5c412f30bfff0562c6701b8ec1f9632d9d2e5ff8ea6013073 SHA512 e0d0cc0f3dee9416eefe430119e8f2f5a9bbc88a214d36d1d23c7e1f7ce78cc977a173f6d22c05cb928715d5c657ba29738f60453323b25299dddc08d57595d2
diff --git a/dev-python/fuse-python/fuse-python-1.0.5.ebuild b/dev-python/fuse-python/fuse-python-1.0.5.ebuild
new file mode 100644
index 000000000000..a00df7c82c9c
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-1.0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-fuse-${PV}
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="https://github.com/libfuse/python-fuse"
+SRC_URI="
+ https://github.com/libfuse/python-fuse/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"