summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-11-20 12:03:15 +0100
committerPacho Ramos <pacho@gentoo.org>2022-11-20 12:08:06 +0100
commit86efe7371ca63fc4655a1dc9caa4bccdbbec1d83 (patch)
treeb672032ead6ce9793305bbb62f51e5c68b687c25
parentnet-wireless/gr-scopy: Add gr-3.10 support (diff)
downloadgentoo-86efe737.tar.gz
gentoo-86efe737.tar.bz2
gentoo-86efe737.zip
games-arcade/xbill: Disable gtk2 gui
As it is EOL for a long time, use Athena as most distros are doing. Also use an icon with higher resolution. Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--games-arcade/xbill/Manifest1
-rw-r--r--games-arcade/xbill/xbill-2.1-r6.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/games-arcade/xbill/Manifest b/games-arcade/xbill/Manifest
index b1b8dba1c1fb..2de057050fc8 100644
--- a/games-arcade/xbill/Manifest
+++ b/games-arcade/xbill/Manifest
@@ -1 +1,2 @@
DIST xbill-2.1.tar.gz 77610 BLAKE2B aeadc62fa01a3d37b1ae6388987e5d5e3a2d73b9c5afa99b9a2c61155eeb5fb2efc4a36dd2cbeb3fd2f677b385550146d75964afa5f7e83a27f6dc7a16db83c9 SHA512 127604d88258db0ec47084209c656f8817146d70b0fe16f5a1d79883415cf38200594834b39080d78c627104ae6d204f3c12caf127fa094108c4edfbfa98d966
+DIST xbill.png 49325 BLAKE2B a2b5cacee2f5aaf62bcea941dbde26c4cf17ef29c0018ecbd66aefb64e6d1240ac756a32b84d631e4675774b7a06d7c56756debe80df8252684181e0e638a9a0 SHA512 cb41e8603f400cf7b4f8fde2739e798872cefd6e45ff0ff17ddf1f02958f572195022adcdc7ac308cb4236fb79ff68433673cfbaefaf5ccdb426d6070f39e854
diff --git a/games-arcade/xbill/xbill-2.1-r6.ebuild b/games-arcade/xbill/xbill-2.1-r6.ebuild
new file mode 100644
index 000000000000..e17560bf50eb
--- /dev/null
+++ b/games-arcade/xbill/xbill-2.1-r6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="A game about an evil hacker called Bill!"
+HOMEPAGE="http://www.xbill.org/"
+SRC_URI="http://www.xbill.org/download/${P}.tar.gz
+ https://dashboard.snapcraft.io/site_media/appmedia/2018/04/xbill.png"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ acct-group/gamestat
+ media-fonts/font-misc-misc
+ x11-libs/libXaw
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-motif \
+ --disable-gtk \
+ --enable-athena
+}
+
+src_install() {
+ default
+ doicon ${DISTDIR}/${PN}.png
+ make_desktop_entry ${PN} XBill ${PN}
+
+ fowners :gamestat /var/lib/xbill/scores /usr/bin/${PN}
+ fperms 664 /var/lib/xbill/scores
+}