summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-21 05:44:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-21 06:14:46 +0200
commit875647c12e2ca96adf7ee1a0ea0d4de3f461e2e3 (patch)
tree64bce0b7baa7f0a6f29ecee10ccc1faffb1fa51d
parentdev-python/natsort: Bump to 8.4.0 (diff)
downloadgentoo-875647c12e2ca96adf7ee1a0ea0d4de3f461e2e3.tar.gz
gentoo-875647c12e2ca96adf7ee1a0ea0d4de3f461e2e3.tar.bz2
gentoo-875647c12e2ca96adf7ee1a0ea0d4de3f461e2e3.zip
dev-python/h5py: Bump to 3.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/h5py/Manifest1
-rw-r--r--dev-python/h5py/h5py-3.9.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index a61e1cbff058..cac65c4a1f7a 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1 +1,2 @@
DIST h5py-3.8.0.tar.gz 400774 BLAKE2B 2e48991225170fbb728fa55a68aea795db42c7eae605d123a24a59a8730220ddc98e88dfbff60220ce8c6952ca7fc0c3e33d472acae09864a29bfe11d90fcca1 SHA512 13397f66a9fc735e1143eb9e3dd584280e955adf49de467bf56c1a98952903720480ab8d505921b7e22c16453498625ad93421a64e520f15ea3566472849a8fd
+DIST h5py-3.9.0.tar.gz 402856 BLAKE2B e2c617c492c2fba751fa546292232b78e1cec4bc75fb50a7c59cdb4a34bc927134d4604d3d9b24f880235cfb356636e66907b8026107547905a77ed9732ccc26 SHA512 f87cb36ba874e86b179776031c3345ad83bc7b5eff2f3ee54acb6b0997cc7925c17dc478957103ab6bb07d8aaa8593af1d51c3547021a205e9d01c0e36d833a9
diff --git a/dev-python/h5py/h5py-3.9.0.ebuild b/dev-python/h5py/h5py-3.9.0.ebuild
new file mode 100644
index 000000000000..23469e940bb9
--- /dev/null
+++ b/dev-python/h5py/h5py-3.9.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="
+ https://www.h5py.org/
+ https://github.com/h5py/h5py/
+ https://pypi.org/project/h5py/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+# disable mpi until mpi4py gets python3_8
+#IUSE="examples mpi"
+IUSE="examples"
+
+#RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
+DEPEND="
+ sci-libs/hdf5:=[hl(+)]
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/numpy-1.17.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/QtPy[testlib,${PYTHON_USEDEP}]
+ )
+"
+# mpi? ( virtual/mpi )
+# mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+#pkg_setup() {
+# use mpi && export CC=mpicc
+#}
+
+python_prepare_all() {
+ # avoid pytest-mpi dep, we do not use mpi anyway
+ sed -i -e 's:pytest-mpi::' pytest.ini || die
+ distutils-r1_python_prepare_all
+
+ export H5PY_SETUP_REQUIRES=0
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest -m "not mpi"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}