summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Goins <josh@redstrate.com>2023-12-11 14:40:45 -0500
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-25 18:03:53 +0100
commit876cf9338b1c049005072f2c399d64e57e8b3d5f (patch)
treeffcfcd6c446b7c88f98cb24be46da4bd428743b7
parentmedia-video/subtitlecomposer: drop 0.7.1-r3 (diff)
downloadgentoo-876cf9338b1c049005072f2c399d64e57e8b3d5f.tar.gz
gentoo-876cf9338b1c049005072f2c399d64e57e8b3d5f.tar.bz2
gentoo-876cf9338b1c049005072f2c399d64e57e8b3d5f.zip
media-libs/mpvqt: new package, add 1.0.0 imported from kde overlay
Thanks-to: Joshua Goins <josh@redstrate.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/mpvqt/Manifest1
-rw-r--r--media-libs/mpvqt/metadata.xml12
-rw-r--r--media-libs/mpvqt/mpvqt-1.0.0.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/mpvqt/Manifest b/media-libs/mpvqt/Manifest
new file mode 100644
index 000000000000..723bfc260a94
--- /dev/null
+++ b/media-libs/mpvqt/Manifest
@@ -0,0 +1 @@
+DIST mpvqt-1.0.0.tar.xz 36172 BLAKE2B 7b88c9f0e69bb4784087161addb7299d061646dca3e2707ce697a67cfec9f668c894df7479c1ded7ddc1f73f48c127051f6b27f536aca35f272235f1b09bcfc1 SHA512 42b19e74d682e327566559c9d600a8cd98b1a64d01804fccc5f85c990532daf434cc2005bf0af10d3cae78643d512651cfac504193e015538d5f75eaa088f26c
diff --git a/media-libs/mpvqt/metadata.xml b/media-libs/mpvqt/metadata.xml
new file mode 100644
index 000000000000..4b756e71cd97
--- /dev/null
+++ b/media-libs/mpvqt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ <remote-id type="kde-invent">libraries/mpvqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/mpvqt/mpvqt-1.0.0.ebuild b/media-libs/mpvqt/mpvqt-1.0.0.ebuild
new file mode 100644
index 000000000000..990a449f34e3
--- /dev/null
+++ b/media-libs/mpvqt/mpvqt-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.245.0
+QTMIN=6.5.0
+inherit ecm kde.org
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="libmpv wrapper for QtQuick2 and QML"
+HOMEPAGE="https://invent.kde.org/libraries/mpvqt"
+
+LICENSE="|| ( GPL-2 GPL-3 LGPL-3 LGPL-2.1 ) CC-BY-SA-4.0 MIT BSD"
+SLOT="6"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,opengl]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ media-video/mpv:=[libmpv]
+"
+RDEPEND="${DEPEND}"