summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-29 21:22:34 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-29 21:35:00 -0700
commit880d1445d237088ddc3b221153d4d221de1046cd (patch)
tree9207ef94b34bd8fe3bda1c6c8d3211ee6cbd9a71
parentnet-irc/unrealircd: fix USE="class-nofakelag" (diff)
downloadgentoo-880d1445.tar.gz
gentoo-880d1445.tar.bz2
gentoo-880d1445.zip
sys-apps/systemd-tmpfiles: add musl patchset
patches obtained at: http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-core/systemd/systemd Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-apps/systemd-tmpfiles/Manifest1
-rw-r--r--sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild10
2 files changed, 10 insertions, 1 deletions
diff --git a/sys-apps/systemd-tmpfiles/Manifest b/sys-apps/systemd-tmpfiles/Manifest
index 0e7a4c8589dd..ff1d4d1bf450 100644
--- a/sys-apps/systemd-tmpfiles/Manifest
+++ b/sys-apps/systemd-tmpfiles/Manifest
@@ -1 +1,2 @@
DIST systemd-246.tar.gz 9534036 BLAKE2B 71b72abcd4d066d35d45d9835d41bec8faa9a7eddc80b48fe7073223f07d32f78a8442c52dc0800940f9750d9c5502123a633738981d797cf610d85df2035bf0 SHA512 7103f7da53f7ced3b5543c238f23bd11c82af8e37166c1720a90576b6b431b4329320c78726166c65a9f5e101dd465c0a86dd13c586c4e55e608a6273d8f324f
+DIST systemd-tmpfiles-246-musl.tar.xz 25860 BLAKE2B 87fc4ca37abec9c1a0cee48bf78c575bd53e16a50d427eff338159dc6d5474ffd328af533ccf90a0e1e160a16baa7378070f418f2be0d7f77e00907a5d07d30e SHA512 4a93d9f0cb2df2dd0a2f91820615dd3a95d19583f45dc0589e37ceaedfc2040112310a6e3fc525e28e222e96a91498af2fe8541b5bf86a635c0f52dd1a84deb7
diff --git a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
index 5ca307a1443d..7585b1486ec6 100644
--- a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
+++ b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
@@ -8,7 +8,8 @@ inherit meson
DESCRIPTION="Creates, deletes and cleans up volatile and temporary files and directories"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd"
-SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
+SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz
+ elibc_musl? ( https://dev.gentoo.org/~gyakovlev/distfiles/${P}-musl.tar.xz )"
LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0"
@@ -39,6 +40,13 @@ BDEPEND="
S="${WORKDIR}/systemd-${PV}"
+src_prepare() {
+ # musl patchset from:
+ # http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-core/systemd/systemd
+ use elibc_musl && eapply "${WORKDIR}/${P}-musl"
+ default
+}
+
src_configure() {
# disable everything until configure says "enabled features: ACL, tmpfiles"
local systemd_disable_options=(