summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-03 22:27:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-03 23:54:49 +0200
commit8996b404da8096a5a710a775e3adc125e2462f65 (patch)
treeb143ca38830dadab2a370a94397aa4c3afe74c1a
parentdev-python/zipp: Bump to 3.8.0 (diff)
downloadgentoo-8996b404.tar.gz
gentoo-8996b404.tar.bz2
gentoo-8996b404.zip
dev-python/rich: Bump to 12.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-12.1.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 86b25f2ab64b..d734d1cb1fe9 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,4 @@
DIST rich-11.2.0.gh.tar.gz 16300346 BLAKE2B 520f512a7e26613a4cc881834f8c150963b84a6dc3a43029dde6d64d1e405d82422b9c6f0098293b6f9bdb55749c7929426dad14840c9a287889c1a6a70f6bf2 SHA512 ec1178a6a320a48f589ead5163e974725f79ae63ddf9a2deb66400e43619ade8d366dbef6b524e66e603647a957b8e26266845a0bcb85912fd9ad2a81dd92f5e
DIST rich-12.0.0.gh.tar.gz 14727980 BLAKE2B b9f7761ab1084765f804fd22f9fb18e659f91b917bb452217752683f6d61320d2703eee28de3be3bd70009fc06d04165528393c4c0ec32a49b1dc7e94989a224 SHA512 4e47e48709180ef844bcf1cd516b22de8a4f22c5121ca0582a2cff7297d97afe63232926d518cd2bf4d6d1a7cea362ab12e71eedacce6b6d378ef1a1528d9e4c
DIST rich-12.0.1.gh.tar.gz 14857207 BLAKE2B 8e6419904ef0ba91d4b15059630f63769a28323600cb212f07c2a239201489e2078b8c4c792f486bde75efd9d09afe832fa2e2235ac91433ee24b33fcda02e68 SHA512 61077663b46a7e615b29df3b75b15ef97979c804abd283cc26f217ee8128b74a514fd7b92831d1d8928f768d2ec8230d8cd1da733106b424704a3187ee18ce95
+DIST rich-12.1.0.gh.tar.gz 14883003 BLAKE2B f11642b5a90934e95dd7d71707617c8a3a1680644dafa9535f86ed5648f14389cddd968c329d4d94649c15123dd00045e0e9e7bb3314be3e6bbc72ba67c100e1 SHA512 6144af9b8843592d586e1c54d5bd97b6974a2510746319c7c0e961f04515ab837088bde2d0876e1a3d33eff40f4dfd8babc3c3f8123f6a4472b7a3eca580d131
diff --git a/dev-python/rich/rich-12.1.0.ebuild b/dev-python/rich/rich-12.1.0.ebuild
new file mode 100644
index 000000000000..4cbcc9174b3c
--- /dev/null
+++ b/dev-python/rich/rich-12.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/Textualize/rich"
+SRC_URI="
+ https://github.com/Textualize/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}