summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-13 12:52:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-13 12:54:39 +0100
commit8abf23df6b6046652f5989359b80bb43bbd37d6c (patch)
tree3541ad34bd00d978877fc569809b5be6d8fe75aa
parentdev-python/boto3: Bump to 1.16.53 (diff)
downloadgentoo-8abf23df6b6046652f5989359b80bb43bbd37d6c.tar.gz
gentoo-8abf23df6b6046652f5989359b80bb43bbd37d6c.tar.bz2
gentoo-8abf23df6b6046652f5989359b80bb43bbd37d6c.zip
www-servers/tornado: Bump to 6.1
Closes: https://bugs.gentoo.org/765184 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--www-servers/tornado/Manifest1
-rw-r--r--www-servers/tornado/tornado-6.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-servers/tornado/Manifest b/www-servers/tornado/Manifest
index be07c5991762..5b9916897059 100644
--- a/www-servers/tornado/Manifest
+++ b/www-servers/tornado/Manifest
@@ -1 +1,2 @@
DIST tornado-6.0.4.tar.gz 496204 BLAKE2B 6c092214d03baf5cf7615b780043e2fa40a4ed623b7ca59a2528cc3625ba904b21ef93c528278adedaf83e3b6e5a6311d867833dfe9826637e97918dee6fa334 SHA512 d29d69cf40f8b34fb2c55d81b6ecd9bc7c6fdf644eb4ff35452829510c0d5ec185da0a6067fec3e8afb2bedf9f5f08b06adb0ad53dcab04cb791a75abc304d6e
+DIST tornado-6.1.tar.gz 497359 BLAKE2B ed5981dec5cca962f907f97b7f906c1eef40d2b2b6d6cc16a21bd0a0a91ee58a60bea84b7ceeeff30b3462d707c56a5062c71d4ac8f25ca6a306ded6c6f072c5 SHA512 0ec1db1fad911182bda547c177a18b107b906cf66576443069e2b986cf041b3d4ebe08e5a168aa5cd3b56547f32f8b384bacaf74db89f582951d7b610b7494e8
diff --git a/www-servers/tornado/tornado-6.1.ebuild b/www-servers/tornado/tornado-6.1.ebuild
new file mode 100644
index 000000000000..23fd9623ccf9
--- /dev/null
+++ b/www-servers/tornado/tornado-6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="https://www.tornadoweb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-asyncio
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ cd "${BUILD_DIR}/lib" || die
+ "${PYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}