summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 07:20:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-06 07:26:50 +0200
commit8b137679765bea294b1c9019a9262a90bf6fbd98 (patch)
tree895b5d217961f8ded00e68af814612534ad43ac3
parentdev-python/apsw: Bump to 3.38.5_p1 (diff)
downloadgentoo-8b137679765bea294b1c9019a9262a90bf6fbd98.tar.gz
gentoo-8b137679765bea294b1c9019a9262a90bf6fbd98.tar.bz2
gentoo-8b137679765bea294b1c9019a9262a90bf6fbd98.zip
dev-python/qtconsole: Bump to 5.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/qtconsole/Manifest1
-rw-r--r--dev-python/qtconsole/qtconsole-5.3.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index e9ac0c65e6e4..16cc25ddc79d 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,2 +1,3 @@
DIST qtconsole-5.2.2.tar.gz 429610 BLAKE2B 1a9f163dfa8a2d38829b2db5a5589b80605b82f144d95e51e3668f296b8e839fd3045c813505926a4c8690e438e79d82c0307c33416152d28899b2f0324aec1e SHA512 43727a08a0b828421bb051063055b3306a2111bedfd148aea6bccc04e103bbffb798c35440bfdb82ffa6bf17a2b0ce9e1ad2d0b3df9aaea294a23dcf582dfd57
DIST qtconsole-5.3.0.tar.gz 430258 BLAKE2B 883c95124d911b17a1cebedc357f207e042a9679a09eb63bace09f7f39eac4b1f3a24ccd372760e3142494208119dc4131939cd82e8cab364dacecca184c8545 SHA512 6fcfaa7ad842f3f45d4e2286ce816a0b4c71e3c3fb07b86589934efcc637e2cd6f5712fa8a10c375b8e86d1e1e6ce32de9f2be2fc0decd554b51c658e106b120
+DIST qtconsole-5.3.1.tar.gz 430680 BLAKE2B 4655d9aa78a95200fb3f4d2016749d4f1c75865d259da8583818259d05301469b9851b85a2716336084f022f546e97ae003483284f0305793da80a5de7635ac2 SHA512 bebf9c97ebe2a030feebd34f9dbc83294af5eb64946b252c5b5e6391e2760ff95efa7f0be89ec59c424de5fefb3f876ead897d17b679fc87896fe440ba936554
diff --git a/dev-python/qtconsole/qtconsole-5.3.1.ebuild b/dev-python/qtconsole/qtconsole-5.3.1.ebuild
new file mode 100644
index 000000000000..e065753cbc2d
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+# The test suite tests both against pyqt5 *and* pyside2
+BDEPEND="
+ test? (
+ dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ EPYTEST_IGNORE=(
+ qtconsole/tests/test_00_console_widget.py
+ qtconsole/tests/test_jupyter_widget.py
+ )
+ epytest
+}