summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-17 09:23:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-17 10:21:41 +0100
commit8c5c476833e82cbff4e59b34e609e374f3f1e478 (patch)
tree214bdbe2d3eaadc0b08d25f072e3bb164f35c9d7
parentdev-python/botocore: Bump to 1.19.19 (diff)
downloadgentoo-8c5c476833e82cbff4e59b34e609e374f3f1e478.tar.gz
gentoo-8c5c476833e82cbff4e59b34e609e374f3f1e478.tar.bz2
gentoo-8c5c476833e82cbff4e59b34e609e374f3f1e478.zip
dev-python/boto3: Bump to 1.16.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.19.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 376c964f91c9..0f6979130f42 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -10,4 +10,5 @@ DIST boto3-1.16.15.tar.gz 338877 BLAKE2B 817fab1f721419cf061b833f1e3e531a0480747
DIST boto3-1.16.16.tar.gz 338959 BLAKE2B e34c14b89ddd402e4ca7037e1fdbb5121ff9eb2c7fefb67eabadb378cc4f8e5f5ddc3c933d366d086155b4b16319ed9e7d85af21bca1da0f17be3c2171dc9c1a SHA512 b0d0cf8877ac66e28f925c3eda6e02c845c8753c96ebb8684d7eb3a3e82ac6323ae8775715bcf7c70889921e53b0224561460cbc0c95ae56a17d606c75245971
DIST boto3-1.16.17.tar.gz 339112 BLAKE2B e5db626fd2a3b1b8a12fbf5f4113c482d4ae0e04eb0b7090ebe75e417c4a3a9a762129a8cfc342fb8550d67b36750de6f5fceccc8a653f27a2201c9be85de466 SHA512 5842cb056ef4b418628778cf0e7c362c6d1175565060008c2ff5fa3b726fccaec96bb1133c8e82788d8f1a2e527fb154a234eb606804f97463e04f0f64c57a1c
DIST boto3-1.16.18.tar.gz 339220 BLAKE2B 795ed9b7f201c36bb12ff8d10484abd92ff36d821817a8fa0be2c8f8a16d352367e9c03a465ce0d27a346121a6974710c42450bb97fe5d844fab57d1fb44b817 SHA512 fdc2e994a3c73d521e88706886f2d5170281e4d83db2804da1aaf3afb1c14a7bf443ec17d15708e6227ca6b069909f89a9ed790c68aec15e35f9b4a9951b2d63
+DIST boto3-1.16.19.tar.gz 339308 BLAKE2B ccd62bd218b3081116cea1eb0e46b5e92d98738aa5709bbda4fdd01cf017e257c70f9e687f64b353c20fed6a74399e6936de136d4e0e809ffe60163ab81b4ac9 SHA512 f629f7d912e636e3fa5e309aa3142e213fe4a0ba30f0862e39290e6f85914f69f15a5e6a3c3f0675818247cf30aa2a58bb6094e273a2af0f9b6e9351c6905a5d
DIST boto3-1.16.9.tar.gz 337905 BLAKE2B ed01e28fd7e62e5e5028307c93f92004bfbecffa77bc2ba1d6574b92ec2c515d910eb5107ac5ee03e0aca909f97f379aa65b5f839c8067634fa69266c58de33f SHA512 7343b8432788ef981819f91fe2ba27c4ec3947d01ff55914f7c89607250ecf60db2da8d25c8a2c7001ef546a9abed4cb744c5937ca09497aa1a983049648bd5e
diff --git a/dev-python/boto3/boto3-1.16.19.ebuild b/dev-python/boto3/boto3-1.16.19.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.19.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}