summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-07 14:57:47 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-12 20:08:17 +0100
commit8db6c8246d3f304e44526de7e3b31dab878cffd3 (patch)
treebc73c311de07600cebf2512bbdf44e3ff9b8ee88
parentnet-analyzer/netdata: [QA] Remove invalid USE=lto (diff)
downloadgentoo-8db6c824.tar.gz
gentoo-8db6c824.tar.bz2
gentoo-8db6c824.zip
net-analyzer/wireshark: [QA] Remove invalid USE=lto
USE=lto is only used to append -flto. Remove it. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-analyzer/wireshark/wireshark-4.0.11.ebuild9
-rw-r--r--net-analyzer/wireshark/wireshark-4.1.0.ebuild9
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild9
-rw-r--r--profiles/base/package.use.mask7
4 files changed, 18 insertions, 16 deletions
diff --git a/net-analyzer/wireshark/wireshark-4.0.11.ebuild b/net-analyzer/wireshark/wireshark-4.0.11.ebuild
index 6c95292c681a..f3715b72f3e7 100644
--- a/net-analyzer/wireshark/wireshark-4.0.11.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.0.11.ebuild
@@ -30,7 +30,7 @@ fi
LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc dpauxmon"
-IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lto lua lz4 maxminddb"
+IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lua lz4 maxminddb"
IUSE+=" +mergecap +minizip +netlink opus +plugins +pcap qt6 +randpkt"
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump wifi zlib +zstd"
@@ -195,7 +195,9 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
- ! use lto && filter-lto
+ # crashes at runtime
+ # https://bugs.gentoo.org/754021
+ filter-lto
mycmakeargs+=(
-DPython3_EXECUTABLE="${PYTHON}"
@@ -239,7 +241,8 @@ src_configure() {
-DENABLE_ILBC=$(usex ilbc)
-DENABLE_KERBEROS=$(usex kerberos)
-DENABLE_LIBXML2=$(usex libxml2)
- -DENABLE_LTO=$(usex lto)
+ # only appends -flto
+ -DENABLE_LTO=OFF
-DENABLE_LUA=$(usex lua)
-DENABLE_LZ4=$(usex lz4)
-DENABLE_MINIZIP=$(usex minizip)
diff --git a/net-analyzer/wireshark/wireshark-4.1.0.ebuild b/net-analyzer/wireshark/wireshark-4.1.0.ebuild
index 5409368db461..17400f26949a 100644
--- a/net-analyzer/wireshark/wireshark-4.1.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.1.0.ebuild
@@ -32,7 +32,7 @@ fi
LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc dpauxmon"
-IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lto lua lz4 maxminddb"
+IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lua lz4 maxminddb"
IUSE+=" +mergecap +minizip +netlink opus +plugins +pcap qt6 +randpkt"
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump wifi zlib +zstd"
@@ -194,7 +194,9 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
- ! use lto && filter-lto
+ # crashes at runtime
+ # https://bugs.gentoo.org/754021
+ filter-lto
mycmakeargs+=(
-DPython3_EXECUTABLE="${PYTHON}"
@@ -238,7 +240,8 @@ src_configure() {
-DENABLE_ILBC=$(usex ilbc)
-DENABLE_KERBEROS=$(usex kerberos)
-DENABLE_LIBXML2=$(usex libxml2)
- -DENABLE_LTO=$(usex lto)
+ # only appends -flto
+ -DENABLE_LTO=OFF
-DENABLE_LUA=$(usex lua)
-DLUA_FIND_VERSIONS="${ELUA#lua}"
-DENABLE_LZ4=$(usex lz4)
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 5409368db461..17400f26949a 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -32,7 +32,7 @@ fi
LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc dpauxmon"
-IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lto lua lz4 maxminddb"
+IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lua lz4 maxminddb"
IUSE+=" +mergecap +minizip +netlink opus +plugins +pcap qt6 +randpkt"
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump wifi zlib +zstd"
@@ -194,7 +194,9 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
- ! use lto && filter-lto
+ # crashes at runtime
+ # https://bugs.gentoo.org/754021
+ filter-lto
mycmakeargs+=(
-DPython3_EXECUTABLE="${PYTHON}"
@@ -238,7 +240,8 @@ src_configure() {
-DENABLE_ILBC=$(usex ilbc)
-DENABLE_KERBEROS=$(usex kerberos)
-DENABLE_LIBXML2=$(usex libxml2)
- -DENABLE_LTO=$(usex lto)
+ # only appends -flto
+ -DENABLE_LTO=OFF
-DENABLE_LUA=$(usex lua)
-DLUA_FIND_VERSIONS="${ELUA#lua}"
-DENABLE_LZ4=$(usex lz4)
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index f3b18e0b0533..5f7495e2bd3e 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -458,13 +458,6 @@ media-sound/puddletag quodlibet
dev-libs/efl mono
# Sam James <sam@gentoo.org> (2021-04-09)
-# Crashes at runtime.
-# Mask LTO for now until issue with Qt
-# (to be resolved in Wireshark?) is resolved
-# bug #754021
-net-analyzer/wireshark lto
-
-# Sam James <sam@gentoo.org> (2021-04-09)
# Fails to build right now
# bug #651740
net-misc/openssh debug