summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-29 10:09:07 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-29 10:09:15 +0100
commit8e19a0a69461674621297d0d902507ed7976fdff (patch)
tree4b3a1938deb8d4a81f9a013e9a899287671ab4f3
parentsci-libs/scipy: Build sequential if python3.5 is involved (diff)
downloadgentoo-8e19a0a6.tar.gz
gentoo-8e19a0a6.tar.bz2
gentoo-8e19a0a6.zip
dev-python/numpy: Build sequential if python3.5 is involved
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573222 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/numpy/numpy-1.10.4.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/numpy/numpy-1.10.4.ebuild b/dev-python/numpy/numpy-1.10.4.ebuild
index 64094286dedf..310c4c6458e9 100644
--- a/dev-python/numpy/numpy-1.10.4.ebuild
+++ b/dev-python/numpy/numpy-1.10.4.ebuild
@@ -117,7 +117,9 @@ python_prepare_all() {
}
python_compile() {
- distutils-r1_python_compile -j $(makeopts_jobs) ${NUMPY_FCONFIG}
+ distutils-r1_python_compile \
+ $(usex python_targets_python3_5 "" "-j $(makeopts_jobs)") \
+ ${NUMPY_FCONFIG}
}
python_test() {