summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:39 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:20 +0100
commit8e659b57137a644e7c03cc192e18917316668439 (patch)
tree9df19035370f43308ffdd0fdf1293c46814917f0
parentdev-haskell/unliftio: add 0.2.23.0-r1 (diff)
downloadgentoo-8e659b57137a644e7c03cc192e18917316668439.tar.gz
gentoo-8e659b57137a644e7c03cc192e18917316668439.tar.bz2
gentoo-8e659b57137a644e7c03cc192e18917316668439.zip
dev-haskell/unordered-containers: add 0.2.19.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/unordered-containers/Manifest2
-rw-r--r--dev-haskell/unordered-containers/metadata.xml11
-rw-r--r--dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild42
3 files changed, 46 insertions, 9 deletions
diff --git a/dev-haskell/unordered-containers/Manifest b/dev-haskell/unordered-containers/Manifest
index 590039b933e3..268e704aecbf 100644
--- a/dev-haskell/unordered-containers/Manifest
+++ b/dev-haskell/unordered-containers/Manifest
@@ -1 +1,3 @@
DIST unordered-containers-0.2.17.0.tar.gz 54110 BLAKE2B 089317f81ce422b1ad54b20bf6c4724a13db855b34e6b4c634e36ed7e897927d2390559f32e8b1f1c38b206c0e8802e066d1f20b3b0a9c3c69a23a01ca993a1b SHA512 e0705e0ad9ec03ad192a8e4047aa5c8a1da6268075be28f423d3f3e7d330084ec02d8499b9f5ee8686c4dd36c67758822d58484155f3ce2cfd210e5bb1a3bb8b
+DIST unordered-containers-0.2.19.1-rev2.cabal 3822 BLAKE2B 57d1cd8fb19b60fc65ec2d89dae387fb9f3475f381507f78142724db810fdb72c706a41740f1e6ce2354dc7536d2dd020d65ef617765f87a9c4e10d9f4ae0ffd SHA512 83afdd11895a1bda7403efae0ff812befe88e26ee90b7098442946d257307bf6fd1eb977dc9b95fa69e24497318ceeb2afd3dfec8d3c0ce87e03a8ad2d5a2a25
+DIST unordered-containers-0.2.19.1.tar.gz 58030 BLAKE2B 52164edda0a384ec9286a5e931f0abb563fe10afc80dff604497d9f78f08ba334243fd0d4603c346d3d1af251e7a74c3962d2cd2592134544ecf79d856bf2236 SHA512 2ea49766210fcec1f8f8bd99c2bb296c4ffcb7ab00317b7663436b6ab0037f9b78cfa22631a1e2bc1f34b6c9b08614aa0ca98c5256ab18258645bfd72351b712
diff --git a/dev-haskell/unordered-containers/metadata.xml b/dev-haskell/unordered-containers/metadata.xml
index a84ebc1e2a38..8bc8285ce7a3 100644
--- a/dev-haskell/unordered-containers/metadata.xml
+++ b/dev-haskell/unordered-containers/metadata.xml
@@ -5,15 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Efficient hashing-based container types. The containers have been
- optimized for performance critical use, both in terms of large data
- quantities and high speed.
-
- The declared cost of each operation is either worst-case or
- amortized, but remains valid even if structures are shared.
- </longdescription>
<upstream>
- <remote-id type="github">tibbe/unordered-containers</remote-id>
+ <remote-id type="hackage">unordered-containers</remote-id>
+ <remote-id type="github">haskell-unordered-containers/unordered-containers</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild b/dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild
new file mode 100644
index 000000000000..c750b2627d64
--- /dev/null
+++ b/dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+#hackport: flags: -debug
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient hashing-based container types"
+HOMEPAGE="https://github.com/haskell-unordered-containers/unordered-containers"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/hashable-1.2.5:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ dev-haskell/chasingbottoms
+ dev-haskell/hunit
+ >=dev-haskell/nothunks-0.1.3
+ >=dev-haskell/quickcheck-2.4.0.1
+ dev-haskell/random
+ >=dev-haskell/tasty-1.4.0.3
+ >=dev-haskell/tasty-hunit-0.10.0.3
+ >=dev-haskell/tasty-quickcheck-0.10.1.2
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-debug
+}