summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-06 01:01:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-06 01:24:56 +0200
commit8fcb174a5ce2b781ba601cc7f5a9246763665560 (patch)
treeceed10ab73a49b297fde4652895b37d1b15ac844
parentsci-biology/qrna: Drop old (diff)
downloadgentoo-8fcb174a.tar.gz
gentoo-8fcb174a.tar.bz2
gentoo-8fcb174a.zip
dev-python/atom: 0.4.1 version bump
Tests either fail or report success with "Ran 0 tests in 0.000s". Not going to carry over the hackish attempt to fix tests from 0.3.10 that only achieves the latter. Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--dev-python/atom/Manifest1
-rw-r--r--dev-python/atom/atom-0.4.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/atom/Manifest b/dev-python/atom/Manifest
index ccd3b3283217..f2c23a694f86 100644
--- a/dev-python/atom/Manifest
+++ b/dev-python/atom/Manifest
@@ -1 +1,2 @@
DIST atom-0.3.10.zip 102102 BLAKE2B ed67aac137ed1ec983d45296756a6cd716201f412783287e2c054edae1d4ac25923fa53af832d77e5ec2c9ce4ee064d2be8013526e41b679235e5eeacccbf39f SHA512 ae22747f96e42b9cc4f7c92ddb7d7b8af647e17b917481cd267d4162bd9260b906a019a73de2ca6e3c72a9430dacd535001da7dcb809c1c3dc18c7297be14b76
+DIST atom-0.4.1.tar.gz 65082 BLAKE2B 9f2f1fe4a910e69a083567472d1d442570b922e1aafd3a94ec55541b406d7fa876a5260193137f9de37b1c44fd97f95d0868fd345cc82e0c1c73683c149aa2e7 SHA512 95c5b5a78fb8466a78b8f983290e722d7f797ecbd9d149e37f2f52f0604c932bb747c791a4d16922535e0ef2c992c59021c2f695563d5a320a86538a6a80b958
diff --git a/dev-python/atom/atom-0.4.1.ebuild b/dev-python/atom/atom-0.4.1.ebuild
new file mode 100644
index 000000000000..a58ad5387d5a
--- /dev/null
+++ b/dev-python/atom/atom-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Memory efficient Python objects"
+HOMEPAGE="https://github.com/nucleic/atom"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}