summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-05-19 10:52:19 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-05-19 11:16:51 +0200
commit8fdf9d89afff1478dcb0f3cb9d6c950a5d13c623 (patch)
treeb2dd00479b3672d7f341dc21a7f2efccc27d0bcb
parentnet-libs/nghttp2: add 1.62.0 (diff)
downloadgentoo-8fdf9d89afff1478dcb0f3cb9d6c950a5d13c623.tar.gz
gentoo-8fdf9d89afff1478dcb0f3cb9d6c950a5d13c623.tar.bz2
gentoo-8fdf9d89afff1478dcb0f3cb9d6c950a5d13c623.zip
x11-plugins/wmbiff: add 0.4.37
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmbiff/Manifest1
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.37.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-plugins/wmbiff/Manifest b/x11-plugins/wmbiff/Manifest
index 7a83388e04ce..245425fe90c9 100644
--- a/x11-plugins/wmbiff/Manifest
+++ b/x11-plugins/wmbiff/Manifest
@@ -1 +1,2 @@
DIST wmbiff-0.4.36.tar.gz 266288 BLAKE2B 7f90ae23ff228ed775c4693beffb3e71930bc594083d75cbe25d9eb992cae3a35bc8d57699da53b034a19486846d05625dee607b0da38519ddfc50faac4cf6da SHA512 b8b14f9676ebd576f9e568bd59638c3000337713c6ef8cf5d7799ed0adea59d1ca1fe0d9c67ceb997814b1e6d26590a0c4052b1f031cee28601d7273bbd3fd23
+DIST wmbiff-0.4.37.tar.gz 242901 BLAKE2B cdba7803306462eb3c1d3cc219c878c4caf2aa6343ccad66aa4d090afa682f09add204d1b2a96ca6451245cb41aefb79abca4223a8dc107c932b5d8f0ad3e830 SHA512 c9874ab0e949033b6ebf84e50ce85ea2c303b2031fb3f02175786d57b3ed4c7240b3e5adfc2dd1556f9afdcfadf2939b338504e02e048ae29a3fb0fbdf0c8c46
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.37.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.37.ebuild
new file mode 100644
index 000000000000..754840fbac99
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.37.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools flag-o-matic
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes"
+HOMEPAGE="https://www.dockapps.net/wmbiff"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1:0
+ >=net-libs/gnutls-2.2.0
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ "${FILESDIR}"/${PN}-0.4.36-ar.patch
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/864855
+ # https://groups.google.com/g/wmaker-dev/c/Z9mU9x4qxs0
+ filter-lto
+
+ econf $(use_enable crypt crypto)
+}