summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-03 18:50:48 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-03 20:30:57 -0500
commit91faf14279dfffe2f390d9e45cd533a783604113 (patch)
tree6605df69f221a8b45075754948be16e70e58591a
parentsys-cluster/pacemaker: drop unstable vulnerable versions (diff)
downloadgentoo-91faf14279dfffe2f390d9e45cd533a783604113.tar.gz
gentoo-91faf14279dfffe2f390d9e45cd533a783604113.tar.bz2
gentoo-91faf14279dfffe2f390d9e45cd533a783604113.zip
dev-util/sysprof-common: Add package
This package installs only the org.gnome.Sysprof3.Profiler.xml file needed by mutter. Previously it was installed by dev-util/sysprof-capture, but the API version of sysprof-capture changed from 3.36 to 3.38 (v3 to v4), necessitating the package being slotted. Since both slot cannot install this file, we have to factor it out into a separate package that x11-wm/mutter can depend on. Bug: https://bugs.gentoo.org/753881 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-util/sysprof-common/Manifest1
-rw-r--r--dev-util/sysprof-common/metadata.xml8
-rw-r--r--dev-util/sysprof-common/sysprof-common-3.38.1.ebuild24
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/sysprof-common/Manifest b/dev-util/sysprof-common/Manifest
new file mode 100644
index 000000000000..833ac9628388
--- /dev/null
+++ b/dev-util/sysprof-common/Manifest
@@ -0,0 +1 @@
+DIST sysprof-3.38.1.tar.xz 458572 BLAKE2B 68c219a6c80ed070314fc7718a2995c49821cc7c761b277fdd29c233da9d81b561b6c68cd0d0a42cc3e4c150e3de438322f7d418140ce19f3381f4ffac78aa1a SHA512 7ba3dd51bd4055dcdf4d46ff87e46537afe42ba009809fdee5ba0ebcdf70776d9e1ff812714096d33b09ac57d459707b92b1ca07682e2f3888b612ca74820442
diff --git a/dev-util/sysprof-common/metadata.xml b/dev-util/sysprof-common/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-util/sysprof-common/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/sysprof-common/sysprof-common-3.38.1.ebuild b/dev-util/sysprof-common/sysprof-common-3.38.1.ebuild
new file mode 100644
index 000000000000..c302f72f5778
--- /dev/null
+++ b/dev-util/sysprof-common/sysprof-common-3.38.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ !=dev-util/sysprof-3.34.1-r0
+ !=dev-util/sysprof-capture-3.36.0-r0
+"
+
+src_install() {
+ insinto /usr/share/dbus-1/interfaces/
+ doins "${S}"/src/org.gnome.Sysprof3.Profiler.xml
+}