summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-03 18:56:31 +0000
committerSam James <sam@gentoo.org>2021-12-03 18:56:31 +0000
commit92b792402254e0ae4b269fbc48ba75815deb3f19 (patch)
tree4a7662e27ff6cd3e2debbbf176f97c8569a34991
parentmedia-libs/freetype: forbid use of internal/bundled zlib (diff)
downloadgentoo-92b792402254e0ae4b269fbc48ba75815deb3f19.tar.gz
gentoo-92b792402254e0ae4b269fbc48ba75815deb3f19.tar.bz2
gentoo-92b792402254e0ae4b269fbc48ba75815deb3f19.zip
sys-libs/libxcrypt: only show < GCC 10 warning with distcc
The issues should only occur if configure is confused which should only happen with a mismatch between the compiler used for configure and compilation (e.g. distcc). Bug: https://bugs.gentoo.org/823179 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild8
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild
index d73e13788fd3..13858d396505 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild
@@ -43,13 +43,13 @@ python_check_deps() {
}
pkg_pretend() {
- if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
- die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
- fi
-
if has "distcc" ${FEATURES} ; then
ewarn "Please verify all distcc nodes are using the same versions of GCC (>= 10) and Binutils!"
ewarn "Older/mismatched versions of GCC may lead to a misbehaving library: bug #823179."
+
+ if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
+ die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
+ fi
fi
}
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
index b25eb93a2469..fa017859016b 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
@@ -43,13 +43,13 @@ python_check_deps() {
}
pkg_pretend() {
- if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
- die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
- fi
-
if has "distcc" ${FEATURES} ; then
ewarn "Please verify all distcc nodes are using the same versions of GCC (>= 10) and Binutils!"
ewarn "Older/mismatched versions of GCC may lead to a misbehaving library: bug #823179."
+
+ if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
+ die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
+ fi
fi
}