summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-30 07:54:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-30 07:54:49 +0200
commit94e7fe88edfd305f73ba893d9d5e788c1b3fa077 (patch)
tree48857be5e452a2558f5e82e98998bd616150ac0b
parentdev-python/google-api-python-client: Bump to 2.11.0 (diff)
downloadgentoo-94e7fe88edfd305f73ba893d9d5e788c1b3fa077.tar.gz
gentoo-94e7fe88edfd305f73ba893d9d5e788c1b3fa077.tar.bz2
gentoo-94e7fe88edfd305f73ba893d9d5e788c1b3fa077.zip
dev-python/zeroconf: Bump to 0.32.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.32.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 3c80995934d8..b55e551df3db 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1 +1,2 @@
DIST python-zeroconf-0.30.0.gh.tar.gz 64301 BLAKE2B ea0d5e36f3f012f217cbd4eeff0a9cd366496e2f64b06112ee3629ad016c8e28877f62358d5b5fd27387cfe474e488e99a9ad8ca1802f6d23612f99310243c57 SHA512 1f3165500a07525ef182bb60c1804fe2002a33a9f800470bdb32bdfd44a1b8f466a818a4390537674952159e5c0e257cf9e4ca570b1a9936e1cf8be294be6311
+DIST python-zeroconf-0.32.0.gh.tar.gz 115276 BLAKE2B 7084c02f989ebc6db6686b82ce3212158595b87e00567e4857e84790a30a2fa6f688288769d1eb118da485a6755da1ef404765070d26905d10ab45b1d95ca849 SHA512 6a612b39be85e673cffc560ea5bcc16facc5a16a370ff6edb1d4f7ff978a01d6ba249a9b313caca3b3ed0c6463a4914a98063eb89f28268cec1c9a2faa4db611
diff --git a/dev-python/zeroconf/zeroconf-0.32.0.ebuild b/dev-python/zeroconf/zeroconf-0.32.0.ebuild
new file mode 100644
index 000000000000..0fadc7be4ba7
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.32.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect }
+}