summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-08-21 21:55:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-08-21 21:57:25 +0300
commit94eb9b2f39ce7ad02ed628cb09e108b22e7711bb (patch)
treee232ed81d30e63084c5753672fe82bff89372c55
parentnet-misc/mosh: protobuf now needs >=c++14 (diff)
downloadgentoo-94eb9b2f39ce7ad02ed628cb09e108b22e7711bb.tar.gz
gentoo-94eb9b2f39ce7ad02ed628cb09e108b22e7711bb.tar.bz2
gentoo-94eb9b2f39ce7ad02ed628cb09e108b22e7711bb.zip
dev-python/opensearch-py: new package, add 1.1.0, 2.3.0
Added as a possible replacement for elasticsearch, requested by @infra. Anyone can modify the package, I've put myself as maintainer just to have a main "blame" assignee for now. I've added the 2 major version 1.x and 2.x, please don't remove one of them, until further notes. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/opensearch-py/Manifest2
-rw-r--r--dev-python/opensearch-py/metadata.xml13
-rw-r--r--dev-python/opensearch-py/opensearch-py-1.1.0.ebuild41
-rw-r--r--dev-python/opensearch-py/opensearch-py-2.3.0.ebuild45
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/opensearch-py/Manifest b/dev-python/opensearch-py/Manifest
new file mode 100644
index 000000000000..151c3a7da0e5
--- /dev/null
+++ b/dev-python/opensearch-py/Manifest
@@ -0,0 +1,2 @@
+DIST opensearch-py-1.1.0.gh.tar.gz 204905 BLAKE2B d54875ddf57de0338c233abc69fed0df83154977b641f151c268faebfe303d851664abafab40bbf53fd5b24350f4136959130c1cc3be7ea92b616568d10130c8 SHA512 4eb3bc9e981c5293e68496143900bd50d7c3e301c76b080799bd08e5b840a2ec5610c5374f07c5a1f1e91cf3e709647f9585606ac1149fbf464cbe4168516b41
+DIST opensearch-py-2.3.0.gh.tar.gz 392631 BLAKE2B b2e88c98676c8c035f8c295b12b8cd8a7b8f4d6e4b1b4dca76f2417cf9d8c01b16bc36b3bed7f64d91d643aa2ceba681af6eac9b4d1a3d3bfa1a2cb13a53f167 SHA512 8be82ff19b4aa3d44dba8dd3b56676241de1999d6ae91c8414528132a6ed450850bf3b544a858c9fe0a5b188cd0da1196a524f9515e90369f5232c3ca7244d22
diff --git a/dev-python/opensearch-py/metadata.xml b/dev-python/opensearch-py/metadata.xml
new file mode 100644
index 000000000000..76b4ac2da973
--- /dev/null
+++ b/dev-python/opensearch-py/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">opensearch-py</remote-id>
+ <remote-id type="github">opensearch-project/opensearch-py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild b/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild
new file mode 100644
index 000000000000..e8a8167526a5
--- /dev/null
+++ b/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for OpenSearch"
+HOMEPAGE="
+ https://pypi.org/project/opensearch-py/
+ https://github.com/opensearch-project/opensearch-py
+"
+SRC_URI="
+ https://github.com/opensearch-project/opensearch-py/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# Uses 156 GB of RAM for the test suite, needs more work.
+RESTRICT="test"
+
+RDEPEND="
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ )
+"
diff --git a/dev-python/opensearch-py/opensearch-py-2.3.0.ebuild b/dev-python/opensearch-py/opensearch-py-2.3.0.ebuild
new file mode 100644
index 000000000000..07abb4d2627b
--- /dev/null
+++ b/dev-python/opensearch-py/opensearch-py-2.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for OpenSearch"
+HOMEPAGE="
+ https://pypi.org/project/opensearch-py/
+ https://github.com/opensearch-project/opensearch-py
+"
+SRC_URI="
+ https://github.com/opensearch-project/opensearch-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# Uses 156 GB of RAM for the test suite, needs more work.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"