summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 10:25:36 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 14:38:57 +0100
commit95eaf741e0027c8c2c8053248ca702209d563b75 (patch)
tree17dfb1e33f21559852d5088338a38d6b4f82e84c
parentdev-python/ropemode: Clean old up (diff)
downloadgentoo-95eaf741e0027c8c2c8053248ca702209d563b75.tar.gz
gentoo-95eaf741e0027c8c2c8053248ca702209d563b75.tar.bz2
gentoo-95eaf741e0027c8c2c8053248ca702209d563b75.zip
dev-python/rpy: Clean old up
-rw-r--r--dev-python/rpy/Manifest2
-rw-r--r--dev-python/rpy/rpy-2.8.5.ebuild62
-rw-r--r--dev-python/rpy/rpy-2.8.6.ebuild52
3 files changed, 0 insertions, 116 deletions
diff --git a/dev-python/rpy/Manifest b/dev-python/rpy/Manifest
index ebf67bf97ef3..c69479af4493 100644
--- a/dev-python/rpy/Manifest
+++ b/dev-python/rpy/Manifest
@@ -1,4 +1,2 @@
DIST rpy2-2.6.2.tar.gz 171655 BLAKE2B f590e63dbbb6f5aa9f18d7475136005fa993d32af41e12a8e33fda0232a73d444f83341aa2dac3ec8300cf68de83e377d5f6caabb27b5d439af795126670e286 SHA512 7a060ccc26a03dc93d75edb85d92f1ab31af96ba140932ff8e699cd5855e6078b1e0ffceed135d32deb6c8f273ebcc8b02be38e9b8fc66778cc2adab5745f542
-DIST rpy2-2.8.5.tar.gz 184190 BLAKE2B 077465bcc7dce5af30942a3d52f39da5f5eb1ed9eb1fc75fb9df21fdc8932974cb29735234894f39c238042a614ffce49d61fe565c310f3d2e5eed3f732fe150 SHA512 737649bea67f0cb2a73dfedfe6f342b52bd8e73840b0da6eb64c8a61d25665d74394df6070ed67ec7a59632798e12fce05225e5c1ec5de587f1ae40ce5074b99
-DIST rpy2-2.8.6.tar.gz 191192 BLAKE2B 3c3710b161cc4bbd93992b703c280ff5fab88f0b7eacde132dfe98fa8d28dc19704b065ce0371067d7fbf2d5d97057f4230a5e0e3d2c4d0f8cba64b05d265160 SHA512 614fd404c2bcd51a503e05bd2ea51fe39ddf20b16088496e9d9f0017ccbd06707f26341243c33669ae4ddf5b37ed748546cab9d4d23b9c26fd39319d9831dcfe
DIST rpy2-2.9.0.tar.gz 193062 BLAKE2B 92492821856e516f8f620397cba2e0ffb17718156c7c3a0bc8df8e744f0adf1ea6006e5c762ba99aa142fe06d327a240bf5d616175e81a80d28a21265c9771aa SHA512 55be876fb7316a08f507f3a332ed29d71b52f733c1986482f141e694d66d0e01a51a9c3f0260f6fe0086d7bfbc1f58b678cda4570665e4f1ffdb120c793ef1b2
diff --git a/dev-python/rpy/rpy-2.8.5.ebuild b/dev-python/rpy/rpy-2.8.5.ebuild
deleted file mode 100644
index 46d7f73bd7b0..000000000000
--- a/dev-python/rpy/rpy-2.8.5.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 flag-o-matic virtualx
-
-MYSLOT=2
-MY_PN=${PN}${MYSLOT}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-lang/R-3.2
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-lang/R-3.2[X,png] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-# ggplot2 is an optional test dep but not in portage
-S="${WORKDIR}/${MY_P}"
-
-# Tarball absent of doc files in doc folder
-# https://bitbucket.org/rpy2/rpy2/issues/229
-
-python_prepare() {
- if ! python_is_python3; then
- # https://bitbucket.org/rpy2/rpy2/pull-requests/56
- sed -e '1i# coding=utf-8' \
- -i rpy/rinterface/tests/test_SexpClosure.py \
- -i rpy/rinterface/tests/test_SexpEnvironment.py || die
- fi
-}
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- virtx "${EPYTHON}" -m 'rpy2.tests' || die
-}
diff --git a/dev-python/rpy/rpy-2.8.6.ebuild b/dev-python/rpy/rpy-2.8.6.ebuild
deleted file mode 100644
index 860a83e5bc0e..000000000000
--- a/dev-python/rpy/rpy-2.8.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 flag-o-matic virtualx
-
-MYSLOT=2
-MY_PN=${PN}${MYSLOT}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="http://rpy2.bitbucket.io/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# ggplot2 is a test dep but not in portage
-RESTRICT="test"
-
-RDEPEND="
- >=dev-lang/R-3.2
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-lang/R-3.2[X,png] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- virtx "${EPYTHON}" -m 'rpy2.tests' || die
-}