summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-31 09:49:09 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-02 07:16:13 +0100
commit97dd9dc654a71cc4ee30ee97c803af3313a50b97 (patch)
treeea6929ceee4098efb205a3132c4a01773f05c08c
parentsys-kernel/dracut: add installkernel as optfeature (diff)
downloadgentoo-97dd9dc654a71cc4ee30ee97c803af3313a50b97.tar.gz
gentoo-97dd9dc654a71cc4ee30ee97c803af3313a50b97.tar.bz2
gentoo-97dd9dc654a71cc4ee30ee97c803af3313a50b97.zip
sys-apps/kexec-tools: add installkernel as optfeature
package installs /etc/kernel/postinst.d/90_kexec which will be executed by traditional installkernel (i.e. if the systemd-kernel-install flag is disabled). Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild7
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.24.ebuild7
-rw-r--r--sys-apps/kexec-tools/kexec-tools-9999.ebuild7
3 files changed, 15 insertions, 6 deletions
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild
index c92e41d36170..2f8eea8c0dee 100644
--- a/sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit libtool linux-info systemd
+inherit libtool linux-info optfeature systemd
if [[ ${PV} == "9999" ]] ; then
inherit git-r3 autotools
@@ -121,4 +121,7 @@ pkg_postinst() {
ewarn "in case running system and initramfs do not agree on detected"
ewarn "root device name!"
fi
+
+ optfeature "automatically updating /etc/kexec.conf on each kernel installation" \
+ "sys-kernel/installkernel[-systemd]"
}
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.24.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.24.ebuild
index bfdda831e42d..924cf21eef4a 100644
--- a/sys-apps/kexec-tools/kexec-tools-2.0.24.ebuild
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.24.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit libtool linux-info systemd
+inherit libtool linux-info optfeature systemd
if [[ ${PV} == "9999" ]] ; then
inherit git-r3 autotools
@@ -125,4 +125,7 @@ pkg_postinst() {
ewarn "in case running system and initramfs do not agree on detected"
ewarn "root device name!"
fi
+
+ optfeature "automatically updating /etc/kexec.conf on each kernel installation" \
+ "sys-kernel/installkernel[-systemd]"
}
diff --git a/sys-apps/kexec-tools/kexec-tools-9999.ebuild b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
index 76fed6da99d0..156d90887fc7 100644
--- a/sys-apps/kexec-tools/kexec-tools-9999.ebuild
+++ b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit libtool linux-info systemd
+inherit libtool linux-info optfeature systemd
if [[ ${PV} == "9999" ]] ; then
inherit git-r3 autotools
@@ -125,4 +125,7 @@ pkg_postinst() {
ewarn "in case running system and initramfs do not agree on detected"
ewarn "root device name!"
fi
+
+ optfeature "automatically updating /etc/kexec.conf on each kernel installation" \
+ "sys-kernel/installkernel[-systemd]"
}