summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-26 16:59:14 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-26 16:59:14 +0100
commit9909bceaafa55cd574d17d1f4c7395afcc3e85c6 (patch)
treea42f4188036b01d80e3d52a72f33c247af331083
parentpackage.mask: Last rite sci-biology/consed, sci-biology/phrap, sci-biology/phred (diff)
downloadgentoo-9909bceaafa55cd574d17d1f4c7395afcc3e85c6.tar.gz
gentoo-9909bceaafa55cd574d17d1f4c7395afcc3e85c6.tar.bz2
gentoo-9909bceaafa55cd574d17d1f4c7395afcc3e85c6.zip
sci-mathematics/frobby: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-mathematics/frobby/frobby-0.9.0-r4.ebuild (renamed from sci-mathematics/frobby/frobby-0.9.0-r3.ebuild)32
1 files changed, 14 insertions, 18 deletions
diff --git a/sci-mathematics/frobby/frobby-0.9.0-r3.ebuild b/sci-mathematics/frobby/frobby-0.9.0-r4.ebuild
index ae7086641b0d..14a17f5470f5 100644
--- a/sci-mathematics/frobby/frobby-0.9.0-r3.ebuild
+++ b/sci-mathematics/frobby/frobby-0.9.0-r4.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Software system and project for computations with monomial ideals"
HOMEPAGE="http://www.broune.com/frobby/"
SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
+S="${WORKDIR}/frobby_v${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="doc static-libs"
+IUSE="doc"
RDEPEND="dev-libs/gmp:0=[cxx(+)]"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base )"
-
-S="${WORKDIR}/frobby_v${PV}"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( virtual/latex-base )"
PATCHES=(
- "${FILESDIR}/${PN}-cflags-no-strip-soname.patch"
- "${FILESDIR}/${PN}-gcc-4.7.patch"
- "${FILESDIR}/${PN}-gmp-5.1.patch"
+ "${FILESDIR}"/${PN}-cflags-no-strip-soname.patch
+ "${FILESDIR}"/${PN}-gcc-4.7.patch
+ "${FILESDIR}"/${PN}-gmp-5.1.patch
)
src_prepare() {
@@ -41,22 +40,19 @@ src_configure() {
}
src_compile() {
- emake
- MODE=shared emake library
- use static-libs && emake library
+ emake MODE=shared
+ emake MODE=shared library
use doc && emake docPdf
}
src_install() {
dobin bin/frobby
dolib.so bin/libfrobby.so
- dosym libfrobby.so "${PREFIX}/usr/$(get_libdir)/libfrobby.so.0"
- use static-libs && dolib.a bin/libfrobby.a
+ dosym libfrobby.so /usr/$(get_libdir)/libfrobby.so.0
- insinto /usr/include
- doins src/frobby.h
+ doheader src/frobby.h
- insinto /usr/include/"${PN}"
+ insinto /usr/include/frobby
doins src/stdinc.h
use doc && dodoc bin/manual.pdf