summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 05:01:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 05:50:28 +0100
commit99725b7870093bcd8818952d46b998e603e99b75 (patch)
tree1c9e252bb34d2e41fc43ee7c45e0c0a1dde36906
parentdev-python/botocore: Bump to 1.29.84 (diff)
downloadgentoo-99725b78.tar.gz
gentoo-99725b78.tar.bz2
gentoo-99725b78.zip
dev-python/boto3: Bump to 1.26.84
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.84.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 5bb2da4e4e06..ce9e8baf7953 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.26.80.gh.tar.gz 606204 BLAKE2B ae80c1ec7e99f48844c4eec39df1f6802df1
DIST boto3-1.26.81.gh.tar.gz 611431 BLAKE2B e3f607e4bbd4ae7002168a697c6c3081b3713acbf7d7c8abdb1016b63f9ac5b16ae44255f707272db6a7b4c657210af0ed1c355889b01434683889b28de9d4e7 SHA512 30faa2d60f5f661e4d56a57c5b9d258ad3de260be2a21723b921f2383e290ca0b3d417a4a970ba3defd8f8196deaade2741117393c664b5fe267deab2e210e06
DIST boto3-1.26.82.gh.tar.gz 611850 BLAKE2B fbf4581d616c6978482689e42a5cf8dc846ef91c77bd9f94298bed1ec50cdf41bc999ee81a1dd43b697da282f2774133daf6c6789d7d78b78aeb272c42f91f56 SHA512 8dc96da11d6da19610810c850c69070d25629e583f4eda822c218f4ad09295d25d3ae689a321c6a0c5f0c27e34717c44eb708950b4f37fe1d27f1f48205e5870
DIST boto3-1.26.83.gh.tar.gz 612532 BLAKE2B 2cbb1bdb45fcb594c981df7850bc5d2a50d381a34d995b604edb55787dac8e85e83f9588960b555ddb92672e1564b4287c4fa6998754dcc204942673f3c686d1 SHA512 467c3eeb7f6ad5a863704498109a355cd789b69d43752fc694c78e67a7953c08f42cbe90a442978dfee08ab032f5b562dc84014c0cb02ec607d6f4b299e0246f
+DIST boto3-1.26.84.gh.tar.gz 612921 BLAKE2B cf98272681299aa11454d65a6bf8bc6aa28244803e3d448f01425e62bb5dc01d93e0790ecaf6b2949ea1978130782f5ac282766c8fea94682e33b0cec65e2148 SHA512 d72117cb2f258fccf4a25e201a2dad8e13e8a80a03859edec2f27da01209185cbbb2f02a7924819214a612c6f6d3758ba0aba0047fab1cced3312d1662a7482b
diff --git a/dev-python/boto3/boto3-1.26.84.ebuild b/dev-python/boto3/boto3-1.26.84.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.84.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}