summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:48 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:08 +0100
commit997a4ef45bcd80ccd52fe8ab4216910576d8846c (patch)
treef2a1c40ae96607a36e90291e90e77aa12b0241f1
parentdev-haskell/statistics: add 0.16.2.0 (diff)
downloadgentoo-997a4ef45bcd80ccd52fe8ab4216910576d8846c.tar.gz
gentoo-997a4ef45bcd80ccd52fe8ab4216910576d8846c.tar.bz2
gentoo-997a4ef45bcd80ccd52fe8ab4216910576d8846c.zip
dev-haskell/streaming-commons: add 0.2.2.5
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/streaming-commons/Manifest1
-rw-r--r--dev-haskell/streaming-commons/metadata.xml4
-rw-r--r--dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild33
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-haskell/streaming-commons/Manifest b/dev-haskell/streaming-commons/Manifest
index 9775c25112b7..f4f4a82f11ae 100644
--- a/dev-haskell/streaming-commons/Manifest
+++ b/dev-haskell/streaming-commons/Manifest
@@ -1 +1,2 @@
DIST streaming-commons-0.2.2.4.tar.gz 84330 BLAKE2B 08b729471b3fdc9c5508ffca0e9ce52f38a33b25855f027ae5924e28387e80b369e8c41a33fae49bbb6d5845985954377c2067d56b26995336faa51cb792f83d SHA512 e552bba766e5b816cbd448d1cec86c5c7593f3f13c6da42c74ebf2c9698be3a3174dd922cf70de1b4940b53e580f396a51cebff6b62db305fb0fb48a5c7658bb
+DIST streaming-commons-0.2.2.5.tar.gz 84415 BLAKE2B 0dfe677b3d07e1d125d6b7cd0d55f4e916323b9f9e86a167eb57cd1d149d33b7a860e315ae271efb8a1ba432b9d7c48434151e9cb806f1f77eb286b81e99a115 SHA512 e2e5f401af9c8eefe37596015f8af42225daaf7f0134add1a375b54e30e5b87212943bfa5da3e2f46953eb6942f3efe753e4565e52eb5ba45fef90743708c89d
diff --git a/dev-haskell/streaming-commons/metadata.xml b/dev-haskell/streaming-commons/metadata.xml
index 2d85b0b0ac8c..93054479d7ec 100644
--- a/dev-haskell/streaming-commons/metadata.xml
+++ b/dev-haskell/streaming-commons/metadata.xml
@@ -5,10 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Provides low-dependency functionality commonly needed by various streaming data libraries, such as conduit and pipes.
- </longdescription>
<upstream>
+ <remote-id type="hackage">streaming-commons</remote-id>
<remote-id type="github">fpco/streaming-commons</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild b/dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild
new file mode 100644
index 000000000000..a923bb975e81
--- /dev/null
+++ b/dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common lower-level functions needed by various streaming data libraries"
+HOMEPAGE="https://github.com/fpco/streaming-commons"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-haskell/async:=[profile?]
+ >=dev-haskell/network-2.4.0.0:=[profile?]
+ || ( dev-lang/ghc dev-haskell/process[profile?] )
+ dev-haskell/random:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-8.6.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? (
+ >=dev-haskell/hspec-1.8
+ dev-haskell/quickcheck
+ )
+"