summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-24 22:55:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-24 23:26:49 +0100
commit9b9060fd68135b5e071175fc3f7db977b7c65f6b (patch)
tree2a437a932e5cb0464ae63fb392bccdd69fa6e667
parentsci-mathematics/flocq: new package; add 4.1.0 (diff)
downloadgentoo-9b9060fd68135b5e071175fc3f7db977b7c65f6b.tar.gz
gentoo-9b9060fd68135b5e071175fc3f7db977b7c65f6b.tar.bz2
gentoo-9b9060fd68135b5e071175fc3f7db977b7c65f6b.zip
sci-mathematics/gappa: new package; add 1.4.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/gappa/Manifest1
-rw-r--r--sci-mathematics/gappa/gappa-1.4.1.ebuild43
-rw-r--r--sci-mathematics/gappa/metadata.xml18
3 files changed, 62 insertions, 0 deletions
diff --git a/sci-mathematics/gappa/Manifest b/sci-mathematics/gappa/Manifest
new file mode 100644
index 000000000000..941d4322fa4c
--- /dev/null
+++ b/sci-mathematics/gappa/Manifest
@@ -0,0 +1 @@
+DIST gappa-1.4.1.tar.gz 388314 BLAKE2B 08bc38745fd33a892ef288315bb4eac730c96ddb379ec4689385b63a9f1f74a662bc303f8323bf3941875b6d38e988fe4114e0db84994a7e7a5858b178cc0026 SHA512 bae9788fdce92b04b011b9de207a1234215cbb68c8bd0a60d925fa5fb5e1cad014d60ed8b45d84e8fabd6b54a870a70af6dd24dd68f4dbb2e129f83dcf88fa11
diff --git a/sci-mathematics/gappa/gappa-1.4.1.ebuild b/sci-mathematics/gappa/gappa-1.4.1.ebuild
new file mode 100644
index 000000000000..ccbc7161da2a
--- /dev/null
+++ b/sci-mathematics/gappa/gappa-1.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER=doxygen
+DOCS_DIR=doc/doxygen
+
+inherit docs multiprocessing
+
+DESCRIPTION="Tool for verifying floating-point or fixed-point arithmetic"
+HOMEPAGE="https://gappa.gitlabpages.inria.fr/
+ https://gitlab.inria.fr/gappa/gappa/"
+SRC_URI="https://gappa.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="CeCILL-2 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS INSTALL.md NEWS.md README.md )
+
+src_compile() {
+ ./remake --jobs=$(makeopts_jobs) || die
+
+ docs_compile
+}
+
+src_test() {
+ ./remake --jobs=$(makeopts_jobs) check || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+
+ einstalldocs
+}
diff --git a/sci-mathematics/gappa/metadata.xml b/sci-mathematics/gappa/metadata.xml
new file mode 100644
index 000000000000..d91a4022ddfa
--- /dev/null
+++ b/sci-mathematics/gappa/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Gappa (Génération Automatique de Preuves de Propriétés Arithmétiques --
+ automatic proof generation of arithmetic properties) is a tool intended to
+ help verifying and formally proving properties on numerical programs
+ dealing with floating-point or fixed-point arithmetic.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.inria.fr/gappa/gappa/-/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>