summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-16 14:16:24 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-16 14:16:38 +1300
commit9bb7ea66fa59fdfba20638d5c160d0f749a66818 (patch)
tree18f9d2c400a79e88ea649960c348d67b99ae4771
parentnet-wireless/uhd: Fix building with GCC-6 (diff)
downloadgentoo-9bb7ea66.tar.gz
gentoo-9bb7ea66.tar.bz2
gentoo-9bb7ea66.zip
dev-perl/CGI-Builder: Fix tests
- EAPI6 - Ensure tests run - Fix tests on newer CGI.pm - Add USE=examples - Add missing deps Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-perl/CGI-Builder/CGI-Builder-1.360.0-r2.ebuild49
-rw-r--r--dev-perl/CGI-Builder/files/CGI-Builder-1.360.0-test-cgipm.patch26
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-perl/CGI-Builder/CGI-Builder-1.360.0-r2.ebuild b/dev-perl/CGI-Builder/CGI-Builder-1.360.0-r2.ebuild
new file mode 100644
index 000000000000..a5c86b1d0bd0
--- /dev/null
+++ b/dev-perl/CGI-Builder/CGI-Builder-1.360.0-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DOMIZIO
+DIST_VERSION=1.36
+DIST_EXAMPLES=( "CBF_examples/*" )
+inherit perl-module
+
+DESCRIPTION="Framework to build simple or complex web-apps"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-perl/OOTools-2.21
+ >=dev-perl/IO-Util-1.5
+ dev-perl/CGI
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-test-cgipm.patch" )
+src_test() {
+ local MODULES=(
+ # https://rt.cpan.org/Ticket/Display.html?id=123292
+ # "Bundle::CGI::Builder::Complete ${DIST_VERSION}"
+ "CGI::Builder ${DIST_VERSION}"
+ "CGI::Builder::Conf"
+ "CGI::Builder::Const"
+ "CGI::Builder::Test"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl_rm_files t/test_pod.t t/test_pod_coverage.t
+ perl-module_src_test
+}
diff --git a/dev-perl/CGI-Builder/files/CGI-Builder-1.360.0-test-cgipm.patch b/dev-perl/CGI-Builder/files/CGI-Builder-1.360.0-test-cgipm.patch
new file mode 100644
index 000000000000..c4fb30fbd9b8
--- /dev/null
+++ b/dev-perl/CGI-Builder/files/CGI-Builder-1.360.0-test-cgipm.patch
@@ -0,0 +1,26 @@
+From 6a8ddfede178b1635f729ed215815c4eff5b8374 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Mon, 16 Oct 2017 13:51:39 +1300
+Subject: Fix tests failing with CGI >= 3.16
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=123293
+---
+ t/02_features.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/02_features.t b/t/02_features.t
+index 96f46dd..9f43b61 100644
+--- a/t/02_features.t
++++ b/t/02_features.t
+@@ -46,7 +46,7 @@
+
+ ; my $ap9 = Test8->new( cgi => CGI->new({ p => 'redirect' }) )
+ ; my $o9 = $ap9->capture('process')
+-; ok( ($$o9 =~ /302 Moved/)
++; ok( ($$o9 =~ /302 Found/)
+ && ($$o9 !~ /never printed/)
+ && ($$o9 !~ /fixup/)
+ && ($$o9 !~ /madness/)
+--
+2.14.2
+