summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-01 20:16:46 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-01 20:43:17 +0200
commit9cd9122b917025bf51694d5ed45e6bead8747be6 (patch)
treea390f6ff41f3624dcf125c3b67cfd9fb51ea7971
parentdev-python/gssapi: fix test calls (diff)
downloadgentoo-9cd9122b.tar.gz
gentoo-9cd9122b.tar.bz2
gentoo-9cd9122b.zip
dev-python/pyamg: fix test calls
Use better way to handle pytest C errors Fixes: 31f75efcb11aefe2502f36facf2f1c329b022233 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pyamg/pyamg-4.2.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/pyamg/pyamg-4.2.1.ebuild b/dev-python/pyamg/pyamg-4.2.1.ebuild
index cdcc0310a2cb..971ced744f5c 100644
--- a/dev-python/pyamg/pyamg-4.2.1.ebuild
+++ b/dev-python/pyamg/pyamg-4.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,7 +32,6 @@ distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
python_test() {
- cp -r -l -n pyamg "${BUILD_DIR}/lib" || die
- cd "${BUILD_DIR}/lib" || die
- epytest
+ cd "${T}" || die
+ epytest --pyargs pyamg
}