summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-29 20:06:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-29 20:17:08 +0200
commit9dd7e98196040225ae96a68005540824758ec879 (patch)
tree76fa5484570a427471a450887218836003270d6e
parentdev-python/qtconsole: Bump to 5.1.1 (diff)
downloadgentoo-9dd7e981.tar.gz
gentoo-9dd7e981.tar.bz2
gentoo-9dd7e981.zip
dev-python/astroid: Bump to 2.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.6.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 03bc16ad2aaf..c60883051c5c 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -2,3 +2,4 @@ DIST astroid-2.5.6.tar.gz 345014 BLAKE2B 13916663aef712449a842e50b74ecd2e1b82817
DIST astroid-2.5.7.tar.gz 352082 BLAKE2B ca52339422da3a35cbe34e4b216dbfed3979dce96a8d5fcc508083c0ef9509c491e78dcfea281b79b07fcb7289a9f40aade0da21ca38b6abcf7025b84909a4fd SHA512 17fc185752510396fda9cce842df8ba72473e469b61c037195a9d6ff72af3ec8d3df01bdcf61d6059d4f90c95278928eba3e3380048bf5c6b4fa2a3c9b267176
DIST astroid-2.5.8.tar.gz 354281 BLAKE2B 70ee47c26b765ba9f9bd40cf120a9ce13709043738e20a08d201cdb899789c6c6bdc604aaab49c78b2888503b46321a1728cce656f39d70ce6877ac088cb9567 SHA512 ab2f413e399810e98bd61c837ac90674e7c6d8e2f4d32f3141b21bf1360c785831fc4afd347e755c97627a04cb482aa4e455897e1c02eec8c5fcd28c54c1e9fc
DIST astroid-2.6.0.tar.gz 358265 BLAKE2B 77db092a9f4368f296a710235bd9d022638c97e3439195f01e55b38ff9e7cbfd204906c353a515ee0bc12f75526866d783ad57aa5d5f69e672e9c1603e48f579 SHA512 44e0833e078948eb1ba1e62710890be8cfc675f7ee136578a39e2914b082fcfbcb90b90a002998471fcd19c4092b9a3c5f71e58af32d3839fa799bcb5bf4a4ba
+DIST astroid-2.6.1.tar.gz 360231 BLAKE2B 4f162f4a32741f36f97df93e1204a0cf9b4ff1d3203a9d0cd48da25e45ac3fcca642123e14e014da24418fa7b137b8bb863f6a4118b32193880e3994f63adca9 SHA512 2efa670edbb2317160c468465541a8a2e78b2fe09939f4d6da5f89516bbe121e347e883aac833aa14a70f20c98d889a414730db0ab836d84a78c91feb8d0ae5a
diff --git a/dev-python/astroid/astroid-2.6.1.ebuild b/dev-python/astroid/astroid-2.6.1.ebuild
new file mode 100644
index 000000000000..316900df58b8
--- /dev/null
+++ b/dev-python/astroid/astroid-2.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local deselect=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker ${deselect[@]/#/--deselect }
+}