summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-30 00:31:02 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-30 00:33:50 +0100
commita272f56304c3f81576ed346dfa3d49257284bc6c (patch)
tree7bad548fa0ba192ab202366b885ff385f5da9b20
parentprofiles: Cleanup obsolete package updates (diff)
downloadgentoo-a272f563.tar.gz
gentoo-a272f563.tar.bz2
gentoo-a272f563.zip
app-portage/unsymlink-lib: Bump to v8
Now with extra actions to help with recovery from fatal failures and detailed error messages with instructions how to recover. Closes: https://bugs.gentoo.org/642578
-rw-r--r--app-portage/unsymlink-lib/Manifest1
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-8.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/Manifest b/app-portage/unsymlink-lib/Manifest
index 4eaddaaab9cb..86e0fdde980f 100644
--- a/app-portage/unsymlink-lib/Manifest
+++ b/app-portage/unsymlink-lib/Manifest
@@ -1,2 +1,3 @@
DIST unsymlink-lib-6.tar.gz 7108 BLAKE2B c11007514b37421c9d1dc0a0f0b55dd56812e04adb63f6d830c44ffb26ff307cfa4671f3345892e1676f90f91ec2b15d20bf95fa949959e99417c8484ddb651f SHA512 52866b74a66c66317502b9b7bc3b4e87d6a6a22a5274f2957fbdef6370ca4fbc49bfe8177ee4ad10739fb86718884aba8e30fc82ec2490463730f6d2eb025bb8
DIST unsymlink-lib-7.tar.gz 7296 BLAKE2B 2e802246b8c19fcac1970c4e23986c515d9f696a9634afdf852dfeadcc64e47fa50d7048b13d5b68e36f357edaf7a40afc189967257442e7aa48e81f6d936853 SHA512 6d296582aca35e16183f967479e1039815ac27c61b1197f5f184e69549ad9ad3ce10b0586a0283aabab8abaa5a0687033c9e8c4f658d504534aa24503bb79136
+DIST unsymlink-lib-8.tar.gz 8080 BLAKE2B 6d8ede65903973aec3c61ab1e920b858d853656163210bc7ddd6ef910779404b9fc92ba57095d96eca6220fdf17ce2906e5573bb27c1385508bee89c9a53a989 SHA512 bbc0d1d9845769af27242d17c75c89f91f90500a15db9b73882901d251ad0642bbae8bc778dede33c9a8931a0c580d632db0bb9117e2379548425e8c8c64b2ff
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-8.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-8.ebuild
new file mode 100644
index 000000000000..6ca4f9fdb17b
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sys-apps/portage[${PYTHON_USEDEP}]"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}