summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-10 03:16:14 +0000
committerSam James <sam@gentoo.org>2024-02-10 03:23:44 +0000
commita3acbd0ea10f94a48837663f6afb123044f6a989 (patch)
treeaad41ff4dc4c6cab9525338a9f1d8eaca2981f97
parentdev-python/aiohttp: only depend on dev-python/regex for tests w/o pypy (diff)
downloadgentoo-a3acbd0ea10f94a48837663f6afb123044f6a989.tar.gz
gentoo-a3acbd0ea10f94a48837663f6afb123044f6a989.tar.bz2
gentoo-a3acbd0ea10f94a48837663f6afb123044f6a989.zip
dev-python/tox: only depend on dev-python/regex for tests w/o pypy
Skip tests importing re_assert for pypy. Bug: https://bugs.gentoo.org/924136 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/tox/tox-4.12.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/tox/tox-4.12.1.ebuild b/dev-python/tox/tox-4.12.1.ebuild
index fc92d9c5ac96..ad54e8f7474c 100644
--- a/dev-python/tox/tox-4.12.1.ebuild
+++ b/dev-python/tox/tox-4.12.1.ebuild
@@ -42,8 +42,8 @@ BDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
+ dev-python/re-assert[${PYTHON_USEDEP}]
dev-python/time-machine[${PYTHON_USEDEP}]
' 'python*')
)
@@ -83,5 +83,10 @@ python_test() {
'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
)
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_IGNORE+=(
+ # requires dev-python/re-assert
+ tests/session/cmd/test_sequential.py
+ )
+
epytest
}