summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-28 05:50:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-03-28 06:42:12 -0400
commita3bc4463d01e20b507710f1ea5584ccffed18218 (patch)
tree5be4104bb0013d7779c721341b3bc4cb30c77fee
parentprofiles: stable use mask dev-ruby/kramdown[unicode] (diff)
downloadgentoo-a3bc4463d01e20b507710f1ea5584ccffed18218.tar.gz
gentoo-a3bc4463d01e20b507710f1ea5584ccffed18218.tar.bz2
gentoo-a3bc4463d01e20b507710f1ea5584ccffed18218.zip
dev-util/maturin: re-enable some tests
Turns out was wrong about cli_tests, it doesn't ignore COLUMNS=80 and rather needs COLUMNS=100 to work right. Unsure what cause it to use 100 and then do 80 if COLUMNS is unset, perhaps the terminal that was used at the time of generation or portage internals are confusing its defaults (not seeing 100 set anywhere in maturin's source/ci?). Also value may not necessarily be right, 100 is just observed as the longest lines in tests/cmd/*.stdout. As for cargo lock, this been skipped since before I picked up maintenance and never quite knew why it fails "sometimes" (may be specific to rust version given I sometime ran into it only while stabilizing using stable rust). Seems to pass right now but may skip again if it comes back as it's not a big deal. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-util/maturin/maturin-0.14.16.ebuild4
-rw-r--r--dev-util/maturin/maturin-1.0.0_beta5.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/dev-util/maturin/maturin-0.14.16.ebuild b/dev-util/maturin/maturin-0.14.16.ebuild
index c0020fd6e2cd..558804d7fb7c 100644
--- a/dev-util/maturin/maturin-0.14.16.ebuild
+++ b/dev-util/maturin/maturin-0.14.16.ebuild
@@ -471,14 +471,12 @@ python_compile_all() {
}
python_test() {
+ local -x COLUMNS=100 # what tests/cmd was generated for
local -x MATURIN_TEST_PYTHON=${EPYTHON}
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
local skip=(
- --skip locked_doesnt_build_without_cargo_lock
- # relies on 80-chars terminal output but ignores exported COLUMNS=80
- --skip cli_tests
# avoid need for wasm over a single hello world test
--skip integration_wasm_hello_world
# fragile depending on rust version, also wants libpypy*-c.so for pypy
diff --git a/dev-util/maturin/maturin-1.0.0_beta5.ebuild b/dev-util/maturin/maturin-1.0.0_beta5.ebuild
index cbe6422f5816..6b69e0607aa9 100644
--- a/dev-util/maturin/maturin-1.0.0_beta5.ebuild
+++ b/dev-util/maturin/maturin-1.0.0_beta5.ebuild
@@ -422,14 +422,12 @@ python_compile_all() {
}
python_test() {
+ local -x COLUMNS=100 # what tests/cmd was generated for
local -x MATURIN_TEST_PYTHON=${EPYTHON}
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
local skip=(
- --skip locked_doesnt_build_without_cargo_lock
- # relies on 80-chars terminal output but ignores exported COLUMNS=80
- --skip cli_tests
# avoid need for wasm over a single hello world test
--skip integration_wasm_hello_world
# fragile depending on rust version, also wants libpypy*-c.so for pypy