summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/maturin/maturin-0.14.16.ebuild4
-rw-r--r--dev-util/maturin/maturin-1.0.0_beta5.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/dev-util/maturin/maturin-0.14.16.ebuild b/dev-util/maturin/maturin-0.14.16.ebuild
index c0020fd6e2cd..558804d7fb7c 100644
--- a/dev-util/maturin/maturin-0.14.16.ebuild
+++ b/dev-util/maturin/maturin-0.14.16.ebuild
@@ -471,14 +471,12 @@ python_compile_all() {
}
python_test() {
+ local -x COLUMNS=100 # what tests/cmd was generated for
local -x MATURIN_TEST_PYTHON=${EPYTHON}
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
local skip=(
- --skip locked_doesnt_build_without_cargo_lock
- # relies on 80-chars terminal output but ignores exported COLUMNS=80
- --skip cli_tests
# avoid need for wasm over a single hello world test
--skip integration_wasm_hello_world
# fragile depending on rust version, also wants libpypy*-c.so for pypy
diff --git a/dev-util/maturin/maturin-1.0.0_beta5.ebuild b/dev-util/maturin/maturin-1.0.0_beta5.ebuild
index cbe6422f5816..6b69e0607aa9 100644
--- a/dev-util/maturin/maturin-1.0.0_beta5.ebuild
+++ b/dev-util/maturin/maturin-1.0.0_beta5.ebuild
@@ -422,14 +422,12 @@ python_compile_all() {
}
python_test() {
+ local -x COLUMNS=100 # what tests/cmd was generated for
local -x MATURIN_TEST_PYTHON=${EPYTHON}
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
local skip=(
- --skip locked_doesnt_build_without_cargo_lock
- # relies on 80-chars terminal output but ignores exported COLUMNS=80
- --skip cli_tests
# avoid need for wasm over a single hello world test
--skip integration_wasm_hello_world
# fragile depending on rust version, also wants libpypy*-c.so for pypy