summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2023-05-04 00:39:01 +0600
committerJoonas Niilola <juippis@gentoo.org>2023-05-07 10:05:00 +0300
commita6455a3c5e15e8fde7fb94dae386361ae274950e (patch)
treeddbd23b4014f59973d5433bdcb1bfb7f50442b7c
parentnet-im/mattermost-desktop-bin: drop 5.2.2 (diff)
downloadgentoo-a6455a3c5e15e8fde7fb94dae386361ae274950e.tar.gz
gentoo-a6455a3c5e15e8fde7fb94dae386361ae274950e.tar.bz2
gentoo-a6455a3c5e15e8fde7fb94dae386361ae274950e.zip
x11-misc/slop: add icu useflag
upstream supports disabling icu/unicode support, so add a useflag for it. Signed-off-by: NRK <nrk@disroot.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-misc/slop/slop-7.6.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-misc/slop/slop-7.6.ebuild b/x11-misc/slop/slop-7.6.ebuild
index eae133af55d8..7a396e8e3619 100644
--- a/x11-misc/slop/slop-7.6.ebuild
+++ b/x11-misc/slop/slop-7.6.ebuild
@@ -12,10 +12,10 @@ KEYWORDS="amd64 ~x86"
LICENSE="GPL-3"
SLOT="0/${PV}"
-IUSE="opengl"
+IUSE="opengl icu"
RDEPEND="
- dev-libs/icu:=
+ icu? ( dev-libs/icu:= )
x11-libs/libX11
x11-libs/libXext
opengl? (
@@ -37,6 +37,9 @@ DEPEND="
PATCHES=( "${FILESDIR}/${PN}"-7.5-missing-header.patch )
src_configure() {
- local mycmakeargs=( -DSLOP_OPENGL=$(usex opengl) )
+ local mycmakeargs=(
+ -DSLOP_OPENGL=$(usex opengl)
+ -DSLOP_UNICODE=$(usex icu)
+ )
cmake_src_configure
}