summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-05-08 22:05:39 -0400
committerZero_Chaos <zerochaos@gentoo.org>2017-05-08 23:08:46 -0400
commita6bc399201d60d84bf71f978a269c9bc72b8ba16 (patch)
tree74c346dd55578986a9fa9bfde5734f33a6b2631c
parentdev-ruby/jsobfu: bump, fix slotting (diff)
downloadgentoo-a6bc399201d60d84bf71f978a269c9bc72b8ba16.tar.gz
gentoo-a6bc399201d60d84bf71f978a269c9bc72b8ba16.tar.bz2
gentoo-a6bc399201d60d84bf71f978a269c9bc72b8ba16.zip
dev-ruby/metasploit-credential: bump, prepping for metasploit bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ruby/metasploit-credential/Manifest1
-rw-r--r--dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/metasploit-credential/Manifest b/dev-ruby/metasploit-credential/Manifest
index a69954646ffb..d3f044af3c8f 100644
--- a/dev-ruby/metasploit-credential/Manifest
+++ b/dev-ruby/metasploit-credential/Manifest
@@ -1 +1,2 @@
DIST metasploit-credential-2.0.3.gem 108032 SHA256 ce275e0d61aa3fba1e19b6b8bedc8c1ce655d44d58a1ca36f798c8762e08ee33 SHA512 df3289756fa26931ae8cdbbfa94efbbd370ac4f6e7acdb3188e6fdcbbe89d4a894cdeb673c0a4608764b1916691f2522bd3e658d97b7742ca7637e17c299ad3a WHIRLPOOL 9d1ba8ed612635b57e5147202823220748583b64abe3c1f1050d134cf2a2e1658e4dddc20174253c53d77d336d3ce11c6b1e8d1ef2de784ec9072a0f232bf150
+DIST metasploit-credential-2.0.8.gem 110080 SHA256 b3d67ff530c92c0d090da633bfe12ecc60d2030d94d5881c42d86e3ba709ec7a SHA512 dac081be5347edd9f96e2e4956824e5982a1ab1ef13dd3113a1a5faf70e4dde570bb42ec404ab503b72ababbdae291d4b929946288452f712bf6a795177e1357 WHIRLPOOL cf99f674535494988866c8d86db19e8d5b8b5467a31a1cd988134dfb930f74ad67d066a0c4a299e4aa1105c89b6e4723f038574b39ea40049d3eeb36ffa49b9a
diff --git a/dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild b/dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild
new file mode 100644
index 000000000000..2f53cf16491e
--- /dev/null
+++ b/dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config db spec"
+
+DESCRIPTION="Code for modeling and managing credentials in Metasploit"
+HOMEPAGE="https://github.com/rapid7/metasploit-credential"
+
+LICENSE="BSD"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+RESTRICT=test
+
+ruby_add_rdepend "dev-ruby/metasploit-concern:2.0
+ >=dev-ruby/metasploit_data_models-1.2.0:*
+ >=dev-ruby/metasploit-model-1.0.0
+ dev-ruby/rubyzip:1
+ dev-ruby/rubyntlm
+ >=dev-ruby/railties-4.2.6:4.2
+ dev-ruby/pg"