summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2023-08-04 08:54:08 +0200
committerStephan Hartmann <sultan@gentoo.org>2023-08-04 08:55:00 +0200
commitac80d3a8a81ae6a7dc68a31dcac519c830980e65 (patch)
treec49769cebf7b108447363f2d77d8cac6fbbd66c2
parentmedia-sound/exaile: bump to 4.1.3 (diff)
downloadgentoo-ac80d3a8.tar.gz
gentoo-ac80d3a8.tar.bz2
gentoo-ac80d3a8.zip
www-client/chromium: fix building with binutils 2.41
Closes: https://bugs.gentoo.org/911687 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
-rw-r--r--www-client/chromium/chromium-115.0.5790.170.ebuild1
-rw-r--r--www-client/chromium/files/chromium-115-binutils-2.41.patch76
2 files changed, 77 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-115.0.5790.170.ebuild b/www-client/chromium/chromium-115.0.5790.170.ebuild
index 665ca347d034..ee04adc672c3 100644
--- a/www-client/chromium/chromium-115.0.5790.170.ebuild
+++ b/www-client/chromium/chromium-115.0.5790.170.ebuild
@@ -341,6 +341,7 @@ src_prepare() {
"${FILESDIR}/chromium-111-InkDropHost-crash.patch"
"${FILESDIR}/chromium-114-gcc12.patch"
"${FILESDIR}/chromium-114-remove-evdev-dep.patch"
+ "${FILESDIR}/chromium-115-binutils-2.41.patch"
)
if use ppc64 ; then
diff --git a/www-client/chromium/files/chromium-115-binutils-2.41.patch b/www-client/chromium/files/chromium-115-binutils-2.41.patch
new file mode 100644
index 000000000000..95f65eb6e33e
--- /dev/null
+++ b/www-client/chromium/files/chromium-115-binutils-2.41.patch
@@ -0,0 +1,76 @@
+From effadce6c756247ea8bae32dc13bb3e6f464f0eb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
+Date: Sun, 16 Jul 2023 18:18:02 +0300
+Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
+ instructions within inline assembly
+
+Fixes assembling with binutil as >= 2.41
+
+Signed-off-by: James Almer <jamrial@gmail.com>
+---
+ libavcodec/x86/mathops.h | 26 +++++++++++++++++++++++---
+ 1 file changed, 23 insertions(+), 3 deletions(-)
+
+diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
+index 6298f5ed19..ca7e2dffc1 100644
+--- a/third_party/ffmpeg/libavcodec/x86/mathops.h
++++ b/third_party/ffmpeg/libavcodec/x86/mathops.h
+@@ -35,12 +35,20 @@
+ static av_always_inline av_const int MULL(int a, int b, unsigned shift)
+ {
+ int rt, dummy;
++ if (__builtin_constant_p(shift))
+ __asm__ (
+ "imull %3 \n\t"
+ "shrdl %4, %%edx, %%eax \n\t"
+ :"=a"(rt), "=d"(dummy)
+- :"a"(a), "rm"(b), "ci"((uint8_t)shift)
++ :"a"(a), "rm"(b), "i"(shift & 0x1F)
+ );
++ else
++ __asm__ (
++ "imull %3 \n\t"
++ "shrdl %4, %%edx, %%eax \n\t"
++ :"=a"(rt), "=d"(dummy)
++ :"a"(a), "rm"(b), "c"((uint8_t)shift)
++ );
+ return rt;
+ }
+
+@@ -113,19 +121,31 @@ __asm__ volatile(\
+ // avoid +32 for shift optimization (gcc should do that ...)
+ #define NEG_SSR32 NEG_SSR32
+ static inline int32_t NEG_SSR32( int32_t a, int8_t s){
++ if (__builtin_constant_p(s))
+ __asm__ ("sarl %1, %0\n\t"
+ : "+r" (a)
+- : "ic" ((uint8_t)(-s))
++ : "i" (-s & 0x1F)
+ );
++ else
++ __asm__ ("sarl %1, %0\n\t"
++ : "+r" (a)
++ : "c" ((uint8_t)(-s))
++ );
+ return a;
+ }
+
+ #define NEG_USR32 NEG_USR32
+ static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
++ if (__builtin_constant_p(s))
+ __asm__ ("shrl %1, %0\n\t"
+ : "+r" (a)
+- : "ic" ((uint8_t)(-s))
++ : "i" (-s & 0x1F)
+ );
++ else
++ __asm__ ("shrl %1, %0\n\t"
++ : "+r" (a)
++ : "c" ((uint8_t)(-s))
++ );
+ return a;
+ }
+
+--
+2.41.0
+