summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-12-01 14:27:19 -0500
committerCraig Andrews <candrews@gentoo.org>2018-12-01 14:40:44 -0500
commitad24ef353b6a1998a659cc747a5c54e5973c47ec (patch)
tree097f4624b269d65f2bd38769559ec345774a2bd6
parentkde5.eclass: Drop obsolete blockers after kde-apps-18.04.3 removal (diff)
downloadgentoo-ad24ef35.tar.gz
gentoo-ad24ef35.tar.bz2
gentoo-ad24ef35.zip
net-p2p/cpuminer-opt: curl is an unconditional dependency, add test
Closes: https://bugs.gentoo.org/651270 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.8.1-r1.ebuild50
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild10
2 files changed, 57 insertions, 3 deletions
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.8.1-r1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.8.1-r1.ebuild
new file mode 100644
index 000000000000..38cf197f4977
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.8.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
index a1f4a660f6b9..38cf197f4977 100644
--- a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ REQUIRED_USE="cpu_flags_x86_sse2"
DEPEND="
dev-libs/gmp:0
dev-libs/jansson
- curl? ( >=net-misc/curl-7.15[ssl] )
+ >=net-misc/curl-7.15[ssl]
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
"
@@ -35,7 +35,7 @@ src_prepare() {
src_configure() {
append-ldflags -Wl,-z,noexecstack
- econf --with-crypto $(use_with curl)
+ econf --with-crypto --with-curl
}
src_install() {
@@ -44,3 +44,7 @@ src_install() {
insinto "/etc/${PN}"
doins cpuminer-conf.json
}
+
+src_test() {
+ ./cpuminer --cputest || die
+}