summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-28 22:26:02 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-28 23:02:00 +0100
commitad83fef538b4efce4b26f09515e815df251b6a0a (patch)
tree261a18308825f0f77c0b665b19cea53ea4a00958
parentdev-python/rich: Bump to 10.15.0 (diff)
downloadgentoo-ad83fef538b4efce4b26f09515e815df251b6a0a.tar.gz
gentoo-ad83fef538b4efce4b26f09515e815df251b6a0a.tar.bz2
gentoo-ad83fef538b4efce4b26f09515e815df251b6a0a.zip
dev-python/hypothesis: Bump to 6.28.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.28.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 67f9c28bcd18..cd4ac6809296 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -7,3 +7,4 @@ DIST hypothesis-python-6.27.0.tar.gz 9172229 BLAKE2B e5d69923579877a4abaa740663a
DIST hypothesis-python-6.27.1.tar.gz 9173425 BLAKE2B 0fa35a863cbddb9bdd592622247abe7a9bdfc6e4624d1a0913b58a47c29d4c507a1aee8f29f9b6080628894a41140801f567bd5b5f1e83b5505b33089992e10b SHA512 3e2f1d4d268f998ccb6bf3784844d82ff3f276074b13c82fabf87a98441764dcbab576348e77ef4c71cd5f6839f92f978e52571f7e290efc680df984eb2ddebe
DIST hypothesis-python-6.27.2.tar.gz 9173689 BLAKE2B 1f3aced11713f272158f8990090ee27cd44f585849ddfb416d636b6390335c717c98a7b1f5060f38118498d08faed00f25e7e51f42eea2efc902720db2b2513e SHA512 eed1f15b8cc739e2c02e234090f937cc8a4ffddf4d44ec4ce1bdf3759cdc12d47c358e29b401f262cd2ffc25485a1db7ff4265870f588282939546300a272426
DIST hypothesis-python-6.27.3.tar.gz 9173846 BLAKE2B d8ba0509ff182cf25b8fbb8c5ade3c3d88fe54fb90203d41db68c1462903623d8ec4817d615cb42ec03948f5bc581a97902a55e73ac427416ac51a7bd067f560 SHA512 497b7e70aa29088dfe7c20be501c537201613813f6c74aec4723a87846ef38494026cb2ad79eb930b1a17b33b65eaf9dfce1411be8a58bc322d6f61f4d62b2f7
+DIST hypothesis-python-6.28.1.tar.gz 9175083 BLAKE2B c5ecd2e62696a57643ca7043a902f08c58c0635bf80e3366921b0c0f6232015f8833fa25ebd20faad01a3b77660c489c25574934e6899dd0a4151b89ad65932c SHA512 4402e7d6030ef79214d9d4b83d165788a3a45bc733aeefb7d70a85fb3d542dc1619943d19cbf7abc3902bf23eecb61a369915bee333abd3347927522ae9ed01d
diff --git a/dev-python/hypothesis/hypothesis-6.28.1.ebuild b/dev-python/hypothesis/hypothesis-6.28.1.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.28.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}