summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 11:42:09 +0100
committerSam James <sam@gentoo.org>2022-09-09 11:42:09 +0100
commitaf314bd8051ea229217c0379113466961f68a869 (patch)
treecb18f221ed10262759aabd664bfeed4d765aae79
parentsys-cluster/ucx: fix build w/ GCC 13 (diff)
downloadgentoo-af314bd8.tar.gz
gentoo-af314bd8.tar.bz2
gentoo-af314bd8.zip
sys-cluster/ucx: add 1.13.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/ucx/Manifest1
-rw-r--r--sys-cluster/ucx/ucx-1.13.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
index bc29771e377d..3acad591f877 100644
--- a/sys-cluster/ucx/Manifest
+++ b/sys-cluster/ucx/Manifest
@@ -1,3 +1,4 @@
DIST ucx-1.10.0_rc5.tar.gz 2399950 BLAKE2B f6f78d2a3e0cd7f252354d59b9d667992c5f9f4d8ee4a41356decf4a1ed72382d8ce5213395bc6bacf1d8658f95808082cc0f825230857ddbbff19ed060efa5c SHA512 b772ad030e80bc5b0ab25d590117950d363f5f7ea1b7ed5ce0bba285d0a932205ee4d73705c094cef077c751b1cf8b6efdd4608c7df6b39d813771a0a31460ac
DIST ucx-1.13.0.tar.gz 2770439 BLAKE2B 779bf7913ec1d0f5aebfd12d4eda90c83f6dae746e82bb818c4d981f6f564ecb37b6e003c3718db4ad74f25aa19fcbeb0ff98ed6349e254b7c707b4dda3c8974 SHA512 bea02adeb5c4286df360cfe788b40afde3e0404c659678497b53e753851e091de766f32aef39bd6f76e71802c88f0e0ed49c31af0c908ce2d9f3edc79ed6f933
+DIST ucx-1.13.1.tar.gz 2979566 BLAKE2B c175f876dda923062a1350b2f3939aca1c9ce3b8a0ee2a50bcc35c72b9f622cc7f4b740194dfdf2b28f56050f05cf4305d903ca0fb35496090691097f2f6d02b SHA512 8ca0876b55326deaf9f756ad8b60b2f6b96d8107d8fc4b9c58b3aad99b161b5a6c4c8a64a924ce35899012959c2d4479eac0309bec05227cf06ffc83dbfc2f6f
DIST ucx-1.9.0.tar.gz 2467338 BLAKE2B 4d2d18c530f99a56baeb1dec88a7dba813970d3f501eb08f637dc7cefcfe5e564bc121e50c1842ea94e927a0fd657847c571241e3dd9601cdde207729d32d721 SHA512 2e8507e9cbba9ea445efdf8be5b5128dfc76cce30111805e9f7a5618bbbbb77d2bb449b6ad5e415f086b3156b63128306671d3a906583248cde720edb4241c67
diff --git a/sys-cluster/ucx/ucx-1.13.1.ebuild b/sys-cluster/ucx/ucx-1.13.1.ebuild
new file mode 100644
index 000000000000..382955d373c3
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.13.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_PV=${PV/_/-}
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="https://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 -riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.13.0-drop-werror.patch
+ "${FILESDIR}"/${PN}-1.13.0-fix-bashisms.patch
+ "${FILESDIR}"/${PN}-1.13.0-fix-fcntl-include-musl.patch
+ "${FILESDIR}"/${PN}-1.13.0-cstdint-include.patch
+ "${FILESDIR}"/${PN}-1.13.0-binutils-2.39-ptr-typedef.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ BASE_CFLAGS="" econf \
+ --disable-compiler-opt \
+ --without-fuse3 \
+ --without-go \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}