summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2021-02-27 18:07:44 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2021-02-27 18:11:21 +0100
commitb1dc735c8d8cfbf6690f302731b7ed530a33ee1d (patch)
treee7d92293a2ab75d3fc1727c50894b55aa436934a
parentapp-admin/syslog-ng: Stabilize 3.30.1 ppc, #769197 (diff)
downloadgentoo-b1dc735c8d8cfbf6690f302731b7ed530a33ee1d.tar.gz
gentoo-b1dc735c8d8cfbf6690f302731b7ed530a33ee1d.tar.bz2
gentoo-b1dc735c8d8cfbf6690f302731b7ed530a33ee1d.zip
net-libs/libgadu: port 1.11.4 to EAPI 7
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org> Closes: https://bugs.gentoo.org/773223
-rw-r--r--net-libs/libgadu/libgadu-1.11.4.ebuild34
-rw-r--r--net-libs/libgadu/libgadu-1.12.2-r1.ebuild2
2 files changed, 18 insertions, 18 deletions
diff --git a/net-libs/libgadu/libgadu-1.11.4.ebuild b/net-libs/libgadu/libgadu-1.11.4.ebuild
index 889a044752bf..7f3392a75a41 100644
--- a/net-libs/libgadu/libgadu-1.11.4.ebuild
+++ b/net-libs/libgadu/libgadu-1.11.4.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils
+inherit autotools
DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
HOMEPAGE="http://toxygen.net/libgadu/"
@@ -17,7 +15,7 @@ RESTRICT="test"
LICENSE="LGPL-2.1"
KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
-IUSE="doc ssl static-libs threads"
+IUSE="doc ssl threads"
COMMON_DEPEND="
sys-libs/zlib
@@ -26,26 +24,28 @@ COMMON_DEPEND="
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )
"
-RDEPEND="${COMMON_DEPEND}
- !=net-im/kadu-0.6.0.2
- !=net-im/kadu-0.6.0.1
-"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
+RDEPEND="${COMMON_DEPEND}"
DOCS=(AUTHORS ChangeLog NEWS README)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
+ --disable-static
+ --disable-tests
--without-openssl
- $(use_with threads pthread)
$(use_with ssl gnutls)
+ $(use_with threads pthread)
)
-
- autotools-utils_src_configure
+ econf "${myeconfargs[@]}"
}
src_install() {
- use doc && HTML_DOCS=(docs/html/)
- autotools-utils_src_install
+ use doc && local HTML_DOCS=( docs/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
}
diff --git a/net-libs/libgadu/libgadu-1.12.2-r1.ebuild b/net-libs/libgadu/libgadu-1.12.2-r1.ebuild
index d7aa78fb95d8..c0f284e5af43 100644
--- a/net-libs/libgadu/libgadu-1.12.2-r1.ebuild
+++ b/net-libs/libgadu/libgadu-1.12.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7