summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-04 09:27:05 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-04 09:43:30 +0100
commitb1fa9d8068ae0e186b253bdcd95f05b0bc36e900 (patch)
tree97561c9fba23d03fbf097347c711a1509d07d0fc
parentapp-emacs/parseedn: bump to 1.2.1 (diff)
downloadgentoo-b1fa9d8068ae0e186b253bdcd95f05b0bc36e900.tar.gz
gentoo-b1fa9d8068ae0e186b253bdcd95f05b0bc36e900.tar.bz2
gentoo-b1fa9d8068ae0e186b253bdcd95f05b0bc36e900.zip
app-emacs/parseclj: bump to 1.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/parseclj/Manifest1
-rw-r--r--app-emacs/parseclj/parseclj-1.1.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/parseclj/Manifest b/app-emacs/parseclj/Manifest
index 4debc08efab7..832aca3453fd 100644
--- a/app-emacs/parseclj/Manifest
+++ b/app-emacs/parseclj/Manifest
@@ -1 +1,2 @@
DIST parseclj-1.1.0.tar.gz 37228 BLAKE2B d0e74eeb3a1ea9cec7445f3e2627d8d6287ff476fdff4a1dd9b3f58100621a02fc0f0369b96bd92fa8f43485d8c45ffa0a7d41681dfe71020157ca467325e2b9 SHA512 ef8da1f65d4f873c81a785aae495128dc551b73cc89cda7c8b37ce8be15b7473c6cbcd886d5ea285ae414a05a02109b60a8cd933720f1a4b6a1e63e07ec33cf8
+DIST parseclj-1.1.1.tar.gz 39388 BLAKE2B cd0303a9bbec275123389308332bb2f5edaae359d67f50c87a90b20ffe544a32e43b6b3160f16535aff820c6029554ab94029047bc4fd21e1dccf20830b09621 SHA512 b28c91a1d9d649cda041a89d1d6ccddc7aa0d6018e7ed45928a7ecebd59a3c1de8559347e695a64d2385477991280db9451a915868d54e272125ecaab951d6d4
diff --git a/app-emacs/parseclj/parseclj-1.1.1.ebuild b/app-emacs/parseclj/parseclj-1.1.1.ebuild
new file mode 100644
index 000000000000..e65c3074b14f
--- /dev/null
+++ b/app-emacs/parseclj/parseclj-1.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Clojure Parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseclj/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md DESIGN.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}